Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 133773 - Provide useful UI for treating files as different mimetype
Provide useful UI for treating files as different mimetype
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Data Systems
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Ondrej Langr
issues@platform
http://ui.netbeans.org/docs/ui/file_t...
:
: 105589 (view as bug list)
Depends on:
Blocks: 106376
  Show dependency treegraph
 
Reported: 2008-04-23 16:07 UTC by Petr Pisl
Modified: 2008-12-22 14:47 UTC (History)
6 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Pisl 2008-04-23 16:07:16 UTC
Up until now there is not an useful UI, which allows to say to NetBeans that files with certain extension should be
treat as files with a mimetype. For example, almost every PHP framework use a files with different extensions. There has
to be a simple way to say this files will be PHP files. 

The current solution with editing mime resolver and restarting ide is not sufficient, is nonintuitive and also danger.
Comment 1 Vladimir Voskresensky 2008-05-16 00:07:01 UTC
Please, add to this the possibility to define default extension. 
Default extension is used when user create something from template.
I.e. C++ users have different extension for their source or header files, so:
1) extensions are configurable
2) using New File template user would like to see file created with preferred (set once as default) extension
3) in case of "New C++ Class" template two files should be generated: source and header. And user expects to have
correct extensions for both as well
Comment 2 Ondrej Langr 2008-05-19 17:22:55 UTC
Since the default extension does not frequently change over time, it should be "remembered" automatically, without user
having to configure it. I've checked the Empty C File Wizard and it does work like this, i.e. the extension is
remembered and the same extension is offered the next time the wizard is started. 
Comment 3 Ondrej Langr 2008-05-21 10:15:07 UTC
UI spec ready, see the URL field. Please raise concerns & feedback if any. If no, please close. 
Comment 4 Ondrej Langr 2008-05-21 10:29:16 UTC
UI spec. moved to public URL. 
Comment 5 Petr Pisl 2008-05-21 12:03:50 UTC
So if I understand correctly from the Option dialog user can change the mimetype for already recognized files. For
example if I want to open xml files in html editor. Is it right?
Comment 6 Ondrej Langr 2008-05-21 12:11:36 UTC
That's right. 
Comment 7 Lukas Hasik 2008-05-22 09:17:18 UTC
LH1: I miss UI specification for the "New File Extension or Pattern" dialog that should open when you click on "New..."
in  File Association tab in Options
Comment 8 Ondrej Langr 2008-05-22 10:10:52 UTC
Thanks for notice, spec. updated. 
Comment 9 Lukas Hasik 2008-05-22 10:53:48 UTC
LH2: another minor thing, when will be the Default button enabled, and what it will be good for? 
Let the spec be complex ;)
Comment 10 Ondrej Langr 2008-05-22 12:53:13 UTC
I thought I would describe detailed functionality in person on today's meeting, but alright .. spec updated ;)
Comment 11 Ondrej Langr 2008-06-04 14:21:58 UTC
Spec. is provided, linked from the URL field. It is now being implemented, closing this enhancement.
Comment 12 Petr Jiricka 2008-06-04 21:10:36 UTC
I would actually leave it open until it is really implemented and added to build. The spec itself is not enough.
Comment 13 Jiri Skrivanek 2008-06-14 12:54:20 UTC
Implementation is added in core-main repository.

http://hg.netbeans.org/core-main/rev/82319770e503
Comment 14 Jiri Skrivanek 2008-06-14 12:57:29 UTC
*** Issue 105589 has been marked as a duplicate of this issue. ***
Comment 15 Petr Jiricka 2008-06-16 13:16:51 UTC
Great, thanks! However, I thought that the new UI would be a *replacement* for the "File Types" and "Object Types"
categories in the advanced options. Right now I still see these in the Advanced options. Is there a plan to remove File
Types and Object Types settings? Thanks.
Comment 16 Jiri Skrivanek 2008-06-16 14:56:11 UTC
Yes, I will remove it soon.
Comment 17 Quality Engineering 2008-06-21 03:58:45 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #272 build
Changeset: http://hg.netbeans.org/main/rev/c2d1a4686344
User: Jiri Skrivanek <jskrivanek@netbeans.org>
Log: #133773 - Added display names of loaders to MIME types.
Comment 18 Lukas Hasik 2008-07-01 10:15:02 UTC
verified in M1
Comment 19 Quality Engineering 2008-07-02 15:40:49 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #295 build
Changeset: http://hg.netbeans.org/main/rev/553d10a92e76
User: Jiri Skrivanek <jskrivanek@netbeans.org>
Log: #133773 - File Types and Object Types nodes removed from advanced options.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo