Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 133662 - GemManager#isGemInstalledForPlatform does not work correctly
GemManager#isGemInstalledForPlatform does not work correctly
Status: VERIFIED FIXED
Product: ruby
Classification: Unclassified
Component: Gems
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Martin Krauskopf
issues@ruby
61fixes1-fixed
:
: 133704 134241 134743 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 13:45 UTC by Martin Krauskopf
Modified: 2008-06-04 08:40 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Krauskopf 2008-04-22 13:45:51 UTC
When there are e.g. versions:

  ruby-debug-base (0.10.1, 0.10.0, 0.9.3)

GemManager#isGemInstalledForPlatform("ruby-debug-base", "0.10.0", true)

returns false, since comparison is performed against latest version only. Original problem pointed by Aaron Brown in
personal communication, thanks.
Comment 1 Martin Krauskopf 2008-04-22 19:44:52 UTC
Fixed in trunk: a4cdefe0ad1a

This is candidate for next 6.1 patch 1 (or whatever it will be). Is there some 'Status whiteboard' or 'Keyword' I should
use for such issues?
Comment 2 Martin Krauskopf 2008-04-22 19:50:59 UTC
*** Issue 133704 has been marked as a duplicate of this issue. ***
Comment 3 Petr Blaha 2008-04-24 16:48:45 UTC
v
Comment 4 Martin Krauskopf 2008-04-30 11:47:04 UTC
*** Issue 134241 has been marked as a duplicate of this issue. ***
Comment 5 jinb 2008-05-07 19:20:55 UTC
backported into release61_fixes by consecutive applying of
http://hg.netbeans.org/main/rev/e1ee085c7722
http://hg.netbeans.org/main/rev/34bf515441b9
http://hg.netbeans.org/main/rev/199895fd8077
http://hg.netbeans.org/main/rev/b5df58420b34
http://hg.netbeans.org/main/rev/d48881ff0d9c
http://hg.netbeans.org/main/rev/a4cdefe0ad1a

Result changeset in release61_fixes branch:
changeset:   77544:67c2ed4f2465
date:        Wed May 07 20:16:19 2008 +0200
summary:     Backport: IZ 133662: GemManager#isGemInstalledForPlatform does not work correctly
Comment 6 Martin Krauskopf 2008-05-08 20:36:13 UTC
*** Issue 134743 has been marked as a duplicate of this issue. ***
Comment 7 kaa 2008-05-20 16:49:08 UTC
I used both default and 16 fontsize
Comment 8 kaa 2008-05-20 16:51:17 UTC
Ignore my comment please.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo