Bug 13355 - F12 does not work to jump to source after error (beeps; focus?)
F12 does not work to jump to source after error (beeps; focus?)
Status: CLOSED DUPLICATE of bug 28728
Product: editor
Classification: Unclassified
Component: -- Other --
3.x
All All
: P3 (vote)
: TBD
Assigned To: issues@editor
issues@editor
: FOCUS
: 29430 31017 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-01 22:27 UTC by Jesse Glick
Modified: 2007-11-05 13:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2001-07-01 22:27:27 UTC
[dev jul 1, MDI] After compiling, and there are errors, Output Window
is selected. Click F12 and it just beeps. The line is selected in the
Source Editor but the Editor does not get focus. It is necessary to
press Ctrl-3 to go to it. Not major but sort of annoying.
Comment 1 lduperval 2001-09-17 17:19:22 UTC
I would just like to note that I still have this problem in the
20010913 build.
Comment 2 David Simonek 2001-09-17 17:26:10 UTC
Yes, thanx for confirmation.
Comment 3 _ ttran 2001-11-08 14:20:06 UTC
works for me in latest (Nov/8) dev (3.3) build 
Comment 4 Martin Roskanin 2003-01-07 15:33:51 UTC
*** Issue 29430 has been marked as a duplicate of this issue. ***
Comment 5 Martin Roskanin 2003-01-07 15:34:56 UTC
Reopening. Issue has been reproduced.
Comment 6 Marian Mirilovic 2003-01-09 15:13:07 UTC
It's easy to reproduce on [nb_dev](20030109), [jdk1.4.2](b12).


Steps to reproduce:
- run IDE
- create two files, both with compilation errors 
- select folder and hit F12
-> output window with compilation errors arises
- press F12 until Source Editor have to switch to the second file,
than if is selected first error from second class -> focus is on the
editor toolbar and not in the editor pane

I am not sure whether this issue hasn't been already filed, so if I
find it I duplicate this one.
Comment 7 Peter Zavadsky 2003-01-28 16:10:16 UTC
It seems to work, just with the focus in that source, described lately.

The problem the focus is on toolbar is problem of the particular
TopComponent implementation.

I think I already passed similar issue to editor (doing same). Either
editor or java module should be responsible for the focus in toolbar,
they implement the component.
Comment 8 Martin Roskanin 2003-01-29 08:36:34 UTC
It is the duplicate of #28728
The focus is on the toolbar.

*** This issue has been marked as a duplicate of 28728 ***
Comment 9 Martin Roskanin 2003-02-13 08:32:30 UTC
*** Issue 31017 has been marked as a duplicate of this issue. ***
Comment 10 Quality Engineering 2003-06-30 18:02:59 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
Comment 11 Quality Engineering 2003-06-30 18:08:30 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo