Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 133517 - I18N - Multibyte chars in names of the Palette elements are shown with square boxes
I18N - Multibyte chars in names of the Palette elements are shown with square...
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: Schema
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Samaresh Panda
issues@xml
61fixes1-fixed
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 19:24 UTC by kaa
Modified: 2008-06-04 08:46 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
element with ja chars in name (65.27 KB, image/jpeg)
2008-04-21 19:25 UTC, kaa
Details
image (59.11 KB, image/jpeg)
2008-04-23 15:32 UTC, kaa
Details
design view (28.75 KB, image/png)
2008-04-23 21:42 UTC, Samaresh Panda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaa 2008-04-21 19:24:21 UTC
Product Version: NetBeans IDE Dev (Build 200804210001)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; MS932; ja_JP (nb)
reproducible with and without --fontsize option.

Steps:
1. Create BPEL Module
2. Add XML Schema
3. Open it and switch to the Design view
4. Add an element using ja_JP chars in its name.

The name was shown with square boxes.
The issue reproducible with utf-8/win-31j project encoding.

It looks close to the issue 132362.
It was about underlined group titles on the Design view. They are looking ok now.
Comment 1 kaa 2008-04-21 19:25:12 UTC
Created attachment 60510 [details]
element with ja chars in name
Comment 2 Ken Frank 2008-04-22 19:22:33 UTC
if this is side effect from fix of 132362 then it probably

should be fixed for the patch1 also.

Andrey, provide details about this here.

ken.frank@sun.com
Comment 3 kaa 2008-04-23 15:31:46 UTC
I believe I checked it before.
Probably it is a side effect of the recent changes. Also I noticed the following behavior:

1. Create XML schema
2. DnD an element
3. Dnd Choice below it

It appears on the diagram with prefix and suffix. They are looking ok in Japanese.

4. Select the Choice at the Diagram

It appears in bold font and its prefix and suffix are now substituted by square boxes.
Comment 4 kaa 2008-04-23 15:32:37 UTC
Created attachment 60608 [details]
image
Comment 5 Ken Frank 2008-04-23 16:35:50 UTC
Erno and Sam,

since I think the fix for these kind of situations is known and not a lot of
code, could the fix for this and others situations
in these modules that Erno had seen be fixed also
for the first patch (like 132362 was), since it means in these
cases either translated messages/labels
or users own use of multibyte would show as boxes,
and user would not know what is there ?

I can file separate issues if needed if can tell me based on code search what other ui items
have this boxes problem.

ken.frank@sun.com

ken.frank@sun.com
Comment 6 Samaresh Panda 2008-04-23 21:39:56 UTC
Sorry, I can't reproduce this. I'm following Ken's instructions on setting up a pseudo localization. When I drag-drop an
element, "newElement" name appears. See attachment.
Comment 7 Samaresh Panda 2008-04-23 21:42:58 UTC
Created attachment 60627 [details]
design view
Comment 8 Ken Frank 2008-04-23 21:56:17 UTC
Sam, please refer to original attachement; I think what is being said
is that if the element name is changed to have multibyte characaters,
that thats the time those chars are seen as square boxes.

in gif you attached the name for the element is "newElement"
or "newComplexType" but in original gif that name was changed
to have multibyte, in other words the name Andrey used is 2 multibyte
characters, thus 2 square boxes.

the multibyte in the other parts of your gif are correct.

Can you try again on windoes using ja characters as the element name ?

ken.frank@sun.com
Comment 9 Samaresh Panda 2008-04-23 22:04:17 UTC
I'm sorry, how can I have Ja characters for element or complex type again? I found another issue: If you drag an element
and hover over an existing element, you get a bulb-info that says "drop here to add...." and I do see square boxes
around it. I'll fix that. For the first one, I need more info.
Comment 10 Samaresh Panda 2008-04-24 01:34:45 UTC
Fix integrated: http://hg.netbeans.org/main/rev/ad809b34cc71.
Note: DV code is complex and hence do not be surprised if you uncover few more.
Comment 11 Ken Frank 2008-04-24 05:06:56 UTC
Andrey, please verify now so we can get it in first patch. thanks.
Comment 12 Erno Mononen 2008-04-24 13:39:22 UTC
I don't see why this fix couldn't be included in patch1 as well, though it is really up to the xml team and sustaining. 
BTW, the fix changes the font style from bold to plain in some places, not sure whether that is intentional or not. 
Also, the change below looks a bit suspicious, why do you need to create the new font using getFontName here?:

--- a/xml.schema.abe/src/org/netbeans/modules/xml/schema/abe/InplaceEditableLabel.java	Wed Apr 23 14:30:01 2008 -0500
+++ b/xml.schema.abe/src/org/netbeans/modules/xml/schema/abe/InplaceEditableLabel.java	Wed Apr 23 19:28:52 2008 -0500
@@ -165,7 +165,9 @@ public class InplaceEditableLabel extend
         if(mouseOverMe && altKeyPressed && (ctrlClickHandler != null) ){
             //draw diff color and underline
             Color origC = getForeground();
-            Font origF = getFont();
+            //Font font = getFont();
+            //Font font = origF.deriveFont((origF.getStyle() | java.awt.Font.PLAIN), origF.getSize()+2);
+            Font font = new Font(getFont().getFontName(), Font.BOLD, getFont().getSize() + 2);
Comment 13 pgebauer 2008-04-24 14:49:26 UTC
The patch nomination process states that the issue must be fixed/verified in the trunk before the nomination. If you
want to get this issue into the patch1, please verify it.
Comment 14 kaa 2008-04-24 17:46:33 UTC
Product Version: NetBeans IDE Dev (Build 200804210001)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; MS932; ja_JP (nb)
utf-8 and win-31j project encodings
Comment 15 Ken Frank 2008-04-24 17:55:52 UTC
to kaa,

how can this be verfied in 200804210001 dev build
when that is the build in which the problem was seen
and fix happened after that date (final fix happened on today 4/24)

am reopening until this can be clarified.


Erno, should another issue for now or future be filed for additional
comments about another part to be fixed ?

ken.frank@sun.com

Comment 16 kaa 2008-04-24 17:58:48 UTC
I copy then paste wrong build version.
I used for verification the following build

Product Version: NetBeans IDE Dev (Build 20080424124045)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; MS932; ja_JP (nb)

please switch bach to verified.
I'll recheck all other issues for this
Comment 17 pgebauer 2008-04-25 13:37:00 UTC
The issue hasn't be fixed till 61patch1 nomination cut-off date.
Marked as release61_fixes_candidate2.
Comment 18 Erno Mononen 2008-04-25 15:40:26 UTC
Ken: Not sure, the usage of getFontName that I mentioned might cause problems, but maybe there was a reason for doing 
it like that. The font style change, if it wasn't intentional, might be an issue depending on the UI guidelines for the 
UI in question here (I'm not familiar with it).
Comment 19 Ken Frank 2008-04-25 19:49:33 UTC
for some reason, andrey did not reverify this as part of the last
comments that it was verified, and since sustaining needs to know
it was verified so can be in patch 1, will resolve and then verify it.

ken.frank@sun.com
Comment 20 Ken Frank 2008-04-25 19:49:51 UTC
verified.
Comment 21 rbalada 2008-04-29 13:16:39 UTC
I've transplanted the changeset http://hg.netbeans.org/main/rev/ad809b34cc71 into release61_fixes repository as
http://hg.netbeans.org/main/rev/bddccd4c0702

changeset:   77485:bddccd4c0702
tag:         tip
user:        samaresh@netbeans.org
date:        Wed Apr 23 19:28:52 2008 -0500
summary:     Issue 133517: i18n square boxes in DV.
Comment 22 rbalada 2008-04-29 13:19:58 UTC
Oops, the correct URL to backported changeset is http://hg.netbeans.org/release61_fixes/rev/bddccd4c0702
Comment 23 kaa 2008-05-20 16:48:25 UTC
rechecked with fcs build and patch1.
The fix looks ok.
Comment 24 kaa 2008-05-20 16:50:09 UTC
used both default and 16 font size


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo