Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 133509 - Change in blank line insertion (6.1 RC2 )
Change in blank line insertion (6.1 RC2 )
Status: RESOLVED DUPLICATE of bug 131954
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
6.x
All Windows XP
: P3 (vote)
: TBD
Assigned To: issues@editor
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 19:10 UTC by stevenable
Modified: 2008-04-22 07:48 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stevenable 2008-04-21 19:10:17 UTC
Moving from V6.0.1 to V6.1 RC2 and started getting more blank lines in my Java source code.  It appears the new
formatter adds a blank line after every in-line comment.

public class Main {
  public static void main(String[] args) {
    int a;
    int b;  // 6.1 RC2 adds blank line after this comment
    int c;
    int d;
  }
}

When reformatted using Alt-Shift-F, V6.0.1 would keep those lines as shown.  But 6.1RC2 adds a blank line apparently due
to the comment. Remove the comment and it won't add the blank line.  I can find nothing in any of my settings that
relate to blank lines and comments and none of the other reported issues appear to be this specific problem.   (This is
not an item I would have expected to change between releases.)  Its annoying and just means I have go back and remove
extraneous blank lines. :(
Comment 1 Jiri Prox 2008-04-22 07:48:53 UTC
This issue is already fixed. The fix will be released in patch 1 for 6.1

*** This issue has been marked as a duplicate of 131954 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo