Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 133402 - Saving CSS file breaks colour coding
Saving CSS file breaks colour coding
Status: VERIFIED FIXED
Product: web
Classification: Unclassified
Component: CSS Visual Tools
6.x
PC Windows Vista
: P2 (vote)
: 6.x
Assigned To: Marek Fukala
Jindrich Sedek
61fixes3-fixed
:
: 134210 134267 134530 134542 134582 134868 136246 138297 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 09:14 UTC by gnewton
Modified: 2008-09-04 13:22 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
CSS file colour coding broken part way through (276.60 KB, image/jpeg)
2008-04-22 00:04 UTC, gnewton
Details
JSPX file with broken colour coding (369.91 KB, image/jpeg)
2008-04-22 00:07 UTC, gnewton
Details
Netbeans log file (41.10 KB, text/plain)
2008-04-22 00:08 UTC, gnewton
Details
sample jspx file (1.72 KB, text/plain)
2008-04-22 11:55 UTC, gnewton
Details
style sheet css file (7.60 KB, text/plain)
2008-04-22 11:56 UTC, gnewton
Details
Still seeing problems after the 19 updates to 6.1 FCS on May 22. (80.18 KB, image/png)
2008-05-26 06:17 UTC, frankioski
Details
Still seeing problems in NetBeans IDE 6.1 (Build 200804211638). See line 16 in attached screen capture. (81.32 KB, image/png)
2008-06-18 07:24 UTC, frankioski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gnewton 2008-04-21 09:14:31 UTC
Saving a CSS file breaks colour coding in JSPX and CSS files.
Colour-coding makes code unreadable.

Steps:
Open a JSPX file, colour coding is as expected
Open a CSS file, colour coding is as expected
change CSS file and save
switch to JSPX file tab, colour coding is broken
switch back to CSS file, colour coding is broken
Comment 1 Jiri Prox 2008-04-21 10:02:02 UTC
Can you provide the screenshot, please?
Comment 2 Vitezslav Stejskal 2008-04-21 14:23:13 UTC
I can't reproduce it in a dev build. What Netbeans build are you using? Are the steps accurate? Would it be possible to
attach the two file you mentioned? Were there any exceptions, maybe also attach Netbeans log file -
<userdir>/var/log/messages.log. Thanks
Comment 3 gnewton 2008-04-22 00:04:58 UTC
Created attachment 60519 [details]
CSS file colour coding broken part way through
Comment 4 gnewton 2008-04-22 00:07:26 UTC
Created attachment 60520 [details]
JSPX file with broken colour coding
Comment 5 gnewton 2008-04-22 00:08:36 UTC
Created attachment 60521 [details]
Netbeans log file
Comment 6 gnewton 2008-04-22 00:10:03 UTC
My build is 6.1RC2

Colour coding profile is CityLights
Comment 7 gnewton 2008-04-22 00:11:56 UTC
Would you like the source .css and .jspx files as well?

No exceptions are visible.
Comment 8 Marek Fukala 2008-04-22 09:32:34 UTC
>Would you like the source .css and .jspx files as well?
Yes please. BTW is it reproducible just on the specific files or is it a generic problem?
Comment 9 Vitezslav Stejskal 2008-04-22 10:01:05 UTC
Yes please, attach the files here. Is this reliably reproducible using the steps that you described? Do you remember if
you imported settings from the previous version when you first started 6.1? If so, could you please also try with a
fresh userdir (eg. use --userdir /tmp/whatever when launching Netbeans)? Thanks a lot
Comment 10 gnewton 2008-04-22 11:55:47 UTC
Created attachment 60544 [details]
sample jspx file
Comment 11 gnewton 2008-04-22 11:56:43 UTC
Created attachment 60545 [details]
style sheet css file
Comment 12 gnewton 2008-04-22 12:08:10 UTC
Ok, saving doesn't actually appear to be the cause of the issue.

To reproduce, have both attached files open, then switch between tabs back and forth before the Navigator panel can
finish painting.

This should cause the colour coding of the smaller file (main.jspx) to break.

I think this has something to do with the size of the file being parsed?

PS I have imported settings from 6.0

I ran Netbeans with a different --userdir, can still reproduce problem
Comment 13 Marek Fukala 2008-04-22 13:04:19 UTC
Hmm, I cannot reproduce with the files you attached. Adding CSS's QE Jindra to CC.
Comment 14 Vitezslav Stejskal 2008-04-23 11:34:03 UTC
The problem is in CSSSemanticAnalyzer...
Comment 15 Vitezslav Stejskal 2008-04-23 11:34:32 UTC
http://hg.netbeans.org/main/rev/30b517780380
Comment 16 Vitezslav Stejskal 2008-04-23 11:36:26 UTC
IMO this is quite serious problem and we should consider adding it to the patch1.
Comment 17 Quality Engineering 2008-04-23 15:54:14 UTC
Issue '133402' Integrated in NB_Trunk_Production #153 : http://hg.netbeans.org/main/rev/30b517780380,
 with comment: #133402 (fixed): CSS semantic analyzer ran only once and since then provided the same results forever
Comment 18 Jindrich Sedek 2008-04-24 07:40:10 UTC
I agree with merging the fix in 61 patch, but I'm not able to reproduce the problem.
I would like to ask reporter to verify the fix in newest build. Use this link

http://bits.netbeans.org/dev/nightly/2008-04-24_02-01-05/

Thanks
Comment 19 Michael Nazarov 2008-04-25 08:13:28 UTC
Unable to reproduce on Build 200804250004.
Going to mark as verified, ok?
Comment 20 pgebauer 2008-04-25 11:27:41 UTC
The issue hasn't be verified till 61patch1 nomination cut-off date.
Marked as release61_fixes_candidate2.
Comment 21 Michael Nazarov 2008-04-25 12:53:28 UTC
Build 200804250004
Comment 22 gnewton 2008-04-26 06:21:30 UTC
Looks ok to me.
Comment 23 Marek Fukala 2008-05-06 12:18:50 UTC
*** Issue 134210 has been marked as a duplicate of this issue. ***
Comment 24 Marek Fukala 2008-05-06 12:19:05 UTC
*** Issue 134542 has been marked as a duplicate of this issue. ***
Comment 25 Marek Fukala 2008-05-06 12:19:37 UTC
*** Issue 134582 has been marked as a duplicate of this issue. ***
Comment 26 Marek Fukala 2008-05-06 12:21:54 UTC
*** Issue 134267 has been marked as a duplicate of this issue. ***
Comment 27 gnewton 2008-05-07 01:27:25 UTC
I note that duplicates have been lodged.
I have noticed that this bug is still occurring.
I will attempt to find a reliable way to reproduce.
Should this be reopened or do the other issues suggest a variation of this issue?
Comment 28 Marek Fukala 2008-05-07 08:36:11 UTC
*** Issue 134530 has been marked as a duplicate of this issue. ***
Comment 29 Marek Fukala 2008-05-07 08:39:28 UTC
gnewton, if you can reproduce the issue on current trunk builds (containing the fix) then yes, please reopen. The fix is
NOT in 6.1 FCS! and should go to 6.1 patch 2. Thanks for your time.
Comment 30 gnewton 2008-05-08 01:18:25 UTC
The following log messages relate to the colour coding breaking an Netbeans deadlocking:

org.apache.jasper.JasperException: PWC6336: Illegal TLD path /WEB-INF/tags/util.tld, must not start with "/WEB-INF/tags"
	at org.apache.jasper.compiler.TldLocationsCache.processTldsInFileSystem(TldLocationsCache.java:519)
	at org.apache.jasper.compiler.TldLocationsCache.processTldsInFileSystem(TldLocationsCache.java:512)
	at org.apache.jasper.compiler.TldLocationsCache.init(TldLocationsCache.java:321)
Caused: org.apache.jasper.JasperException: PWC6180: Unable to initialize TldLocationsCache
	at org.apache.jasper.compiler.TldLocationsCache.init(TldLocationsCache.java:326)
	at org.apache.jasper.compiler.TldLocationsCache.getLocation(TldLocationsCache.java:272)
[catch] at
org.netbeans.modules.web.jspparser_ext.WebAppParseSupport$InitTldLocationCacheThread.run(WebAppParseSupport.java:914)
WARNING [org.openide.loaders]: Should override getLookup() in class org.netbeans.modules.gsf.GsfDataObject, e.g.:
[MultiDataObject.this.]getCookieSet().getLookup()
WARNING [org.openide.filesystems.Ordering]: Not all children in / marked with the position attribute: [comment,
uncomment], but some are: [org-netbeans-modules-css-actions-CssRuleCreateAction.instance, Separator0.instance,
jump-list-last-edit, jump-list-prev, jump-list-next, Separator-before-find-previous.instance, find-selection,
find-previous, find-next, toggle-highlight-search, Separator-after-toggle-highlight-search.instance,
bookmark-previous.shadow, bookmark-next.shadow, bookmark-toggle.shadow, Separator-after-bookmarks.instance,
shift-line-left, shift-line-right, Separator-after-shift-line.instance, start-macro-recording, stop-macro-recording]
INFO [org.netbeans.modules.editor.settings.storage.SettingsType]: Preferences settings should reside in 'Preferences'
subfolder, see #90403 for details. Offending file 'Editors/text/x-css/properties.xml'
Illegal character : <
Illegal character : <
Illegal character : <
Illegal character : <
Illegal character : <
Illegal character : <
Illegal character : <
Illegal character : <
Illegal character : <
Illegal character : <
Illegal character : <
Illegal character : <
WARNING [org.netbeans.modules.html.editor.coloring.EmbeddingUpdater]: startOffset >= endOffset: 6862 >= 6862
Illegal character : <
Illegal character : <
Illegal character : #
Comment 31 Marek Fukala 2008-05-12 09:33:23 UTC
The "crazy" coloring is very likely not related to the exception from the parser. Does the coloring problem happen in
trunk builds under the same circumstances as in 6.1?? Can you attach a threaddump for the deadlock?
Comment 32 Marek Fukala 2008-05-13 09:28:09 UTC
*** Issue 134868 has been marked as a duplicate of this issue. ***
Comment 33 frankioski 2008-05-14 23:24:24 UTC
I tried to test it on the 20080511 trunk build, but that build doesn't work: I can't even open a JSP without it throwing
some error and leaving the editor gray with the word "Loading" in the middle.
Comment 34 Jindrich Sedek 2008-05-15 06:29:00 UTC
you are facing independent P1 bug #134424 that is already fixed 
use todays build
Comment 35 frankioski 2008-05-26 06:17:15 UTC
Created attachment 61890 [details]
Still seeing problems after the 19 updates to 6.1 FCS on May 22.
Comment 36 pslechta 2008-06-03 13:39:48 UTC
Hello mfukala,

can you please fix this bug as soon as possible (till 09-Jun-2008), so it can be part of NB 6.1 patch 2?

Thanks!
Comment 37 pgebauer 2008-06-13 10:24:02 UTC
The issue didn't meet nomination criteria for 61patch2 till nomination cut-off
date. It has been moved to the next patch.
Comment 38 frankioski 2008-06-18 07:24:08 UTC
Created attachment 62971 [details]
Still seeing problems in NetBeans IDE 6.1 (Build 200804211638). See line 16 in attached screen capture.
Comment 39 Marek Fukala 2008-06-18 10:30:14 UTC
pslechta, the issue has been already fixed, please include in upcoming patch (3?).

frankovski, do not reopen the issue if you didn't check in trunk build. The issus was fixed on Apr 23th, and is not
included in any patch so far.
Comment 40 Marek Fukala 2008-06-18 10:31:55 UTC
I am sorry, I ment frankioski, not frankovski.
Comment 41 Vitezslav Stejskal 2008-06-18 14:20:19 UTC
*** Issue 136246 has been marked as a duplicate of this issue. ***
Comment 42 Marek Fukala 2008-06-26 16:54:36 UTC
*** Issue 138297 has been marked as a duplicate of this issue. ***
Comment 43 rbalada 2008-08-04 15:53:53 UTC
Please note that NetBeans 6.1 Patch3 cut-off is going to happen on close of
business August 5th. If you would like to have bugfix for this issue as part of
NetBeans 6.1 Patch3, then this issue must have information about bugfix' trunk
changeset and it's status must be "VERIFIED".
Comment 44 Jindrich Sedek 2008-08-04 15:59:14 UTC
verified.
Comment 45 rbalada 2008-08-04 17:04:16 UTC
I've transplanted the changeset http://hg.netbeans.org/main/rev/30b517780380 into release61_fixes repository as
http://hg.netbeans.org/release61_fixes/rev/07c64a371f15


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo