Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 133134 - Address breakpoint is not shown in the sources
Address breakpoint is not shown in the sources
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Egor Ushakov
issues@cnd
65fixes2-verified
:
: 155034 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-17 17:14 UTC by Alexander Pepin
Modified: 2009-06-25 10:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2008-04-17 17:14:27 UTC
Steps to reproduce:
- create Welcome sample
- do step into project
- switch to disassembler
- set a breakpoint within "cout << "Welcome ...\n";" code
- finish debugger
- set a line BP at return statement
- run debugger
Result: Debugger stops at the Address BP but no annotation is shown. I would propose two possible solution:
1. Disassembler view should appear if process stops at Address BP
2. Special Address BP annotation should appear in source view if a user creates breakpoint in disassembler

IMO the second solution is better.
Comment 1 Egor Ushakov 2008-10-29 12:12:25 UTC
fixed in the changeset:
http://hg.netbeans.org/main/rev/9b03ee1df400
now when we stop at the address breakpoint we always open disassebly view
Comment 2 Alexander Pepin 2008-12-09 15:05:08 UTC
Fix failed in build 200812080201. Annotations disappear in a moment after setting. 
One more inconvenience, Address breakpoints have absolute address in Breakpoints view whereas address in Disassembler
view is shown in relative manner (main+XXX).
Comment 3 Egor Ushakov 2008-12-11 11:56:34 UTC
fixed in the changeset:
http://hg.netbeans.org/main/rev/ae1cfb0b3a07
Comment 4 Egor Ushakov 2008-12-11 12:00:09 UTC
*** Issue 155034 has been marked as a duplicate of this issue. ***
Comment 5 Alexander Pepin 2008-12-12 13:31:27 UTC
fix failed in build 200812120201 on all platforms
Comment 6 Alexander Pepin 2008-12-12 14:39:24 UTC
not included into build 200812120201 but verified with a new org-...-debugger-gdb.jar 
Comment 7 Alexander Pepin 2008-12-15 13:49:23 UTC
verified in build 200812150201
Comment 8 jinb 2009-01-08 18:39:41 UTC
Hello,
it impossible to apply mentioned changeset(s) to release65_fixes [ref1] branch because a lot of non-this IZ related
changes were made and other changesets pushed into main [ref2] repository between release65_fixes branching time and
mentioned changeset(s) pushing time. Please provide cumulative changeset/ set of changesets applicable to
release65_fixes branch otherwise this fix will be skipped for current NB65 patch.
This problem is common for following IZs: 151761, 151610, 151577, 133134, 155487 
[ref1]: http://hg.netbeans.org/release65_fixes
[ref2]: http://hg.netbeans.org/main
Comment 9 Alexander Pepin 2009-01-13 15:14:18 UTC
It would be nice to have the fix in NB 6.5 patch
Comment 10 Egor Ushakov 2009-01-14 09:03:09 UTC
I think that the fix for the issue 155487:
http://hg.netbeans.org/main?cmd=changeset;node=45fb6c89211f
fixes this issue as well (so there is no need to integrate the fix for this issue, only 155487) and it is a very simple
changeset.
In what form should I provide the diff?
Comment 11 Egor Ushakov 2009-01-14 10:36:34 UTC
ups, differences are really too significant :(
Comment 12 Alexander Pepin 2009-01-14 13:57:21 UTC
verified in NB6.5 with provided jar files
Comment 13 _ gordonp 2009-01-14 16:40:14 UTC
> I think that the fix for the issue 155487:
> http://hg.netbeans.org/main?cmd=changeset;node=45fb6c89211f
> fixes this issue as well (so there is no need to integrate the fix
> for this issue, only 155487) and it is a very simple changeset.
> 
> In what form should I provide the diff?

I took care of this with a patch to release65_fixes containing 155487 (and all
other 65fixes2-candidate issues).
Comment 14 jinb 2009-01-14 17:44:23 UTC
Cumulative backport of fixes of IZ 151481(rebackport), 151577, 151610, 153473, 151640, 151761, 155487, 151631, 133134
provided by developer.
Backported into release65_fixes branch
http://hg.netbeans.org/release65_fixes/rev/84a0c7175a4b
Comment 15 Alexander Pepin 2009-01-19 15:12:01 UTC
verified in patch2
Comment 16 jhonner 2009-02-02 01:30:50 UTC
i need the library of c++ for netbeans now
Comment 17 Alexander Pepin 2009-02-02 15:42:33 UTC
please explain the priority escalation and describe your problem


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo