Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 133133 - IDE freezes for a while if user opens Registers view
IDE freezes for a while if user opens Registers view
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
6.x
Macintosh (x86) Mac OS X
: P2 (vote)
: TBD
Assigned To: Egor Ushakov
issues@cnd
61fixes1-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-17 16:55 UTC by Alexander Pepin
Modified: 2009-06-25 10:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
gdb log (17.52 KB, text/plain)
2008-04-17 16:57 UTC, Alexander Pepin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2008-04-17 16:55:47 UTC
Steps to reproduce:
- create Welcome project
- do step into project
- open Registers view
Result: IDE freezes for 30 seconds then empty Registers view appears. If a user switches to another Debugging View (e.g.
Breakpoints) then returns back IDE freezes once again. The constant duration of the freeze hints that it's some kind of
"waiting for reply".
Comment 1 Alexander Pepin 2008-04-17 16:57:33 UTC
Created attachment 60359 [details]
gdb log
Comment 2 Egor Ushakov 2008-04-22 13:09:10 UTC
On Mac we use gdb 6.3 which does not support some operations :(
Comment 3 _ gordonp 2008-04-22 15:39:33 UTC
It looks like a timing issue. You issue the 107-data-list-register-names immediately
after 106-exec-run. On the Mac this doesn't work. You should consider sending your
-data-list-register-names on a PROP_STATE change from STATE_STARTING to STATE_LOADING.
This would mean your command was issues when we stopped at main (or the 1st line of
executable code).

If you choose to do this we probably need to coordinate a better transition from
LOADING to READY. Initially, LOADING was *only* for setting breakpoints and when the
last bp was created we switched to READY. A 2nd check was added to this state and the
transaction became a bit of a kludge. We should probably define the transition better
as its a good spot for making queries to gdb (ie, after we've run to main and gdb and
the debuggee are both initialized).
Comment 4 Egor Ushakov 2008-04-23 15:22:37 UTC
fixed in main with the changeset:
http://hg.netbeans.org/main/rev/6199836dfdcd
Comment 5 Egor Ushakov 2008-04-23 15:27:06 UTC
fixed
Comment 6 Alexander Pepin 2008-04-24 13:50:24 UTC
verified in dev build 20080424003
Comment 7 rbalada 2008-04-29 13:56:07 UTC
I've backported the changeset http://hg.netbeans.org/main/rev/6199836dfdcd into release61_fixes repository as
http://hg.netbeans.org/release61_fixes/rev/75ae4da34385

changeset:   77491:75ae4da34385
tag:         tip
user:        Egor Ushakov <gorrus@netbeans.org>
date:        Wed Apr 23 18:20:07 2008 +0400
summary:     fixed IZ:133133 (IDE freezes for a while if user opens Registers view)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo