Bug 133011 - Local refactorings cause editor to lose focus
Local refactorings cause editor to lose focus
Status: VERIFIED WORKSFORME
Product: java
Classification: Unclassified
Component: Refactoring
6.x
All All
: P4 (vote)
: 7.4
Assigned To: Ralph Ruijs
issues@java
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-16 15:34 UTC by Jesse Glick
Modified: 2013-05-21 14:46 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2008-04-16 15:34:05 UTC
Observed in current dev builds but for quite some time before that too. JDK 6, Ubuntu, Ocean.

If I select some expression in the editor and choose e.g. Refactor > Introduce Variable (by mouse or mnemonic), and
enter the information and accept the dialog, the refactoring is done but the editor loses focus. It is possible to
regain focus e.g. using Ctrl-1 Ctrl-0.
Comment 1 Jaromir Uhrik 2009-05-11 06:31:11 UTC
Since the workaround exists (using Ctrl-1 Ctrl-0) I can confirm that the priority is correctly P3.
Comment 2 Ralph Ruijs 2013-05-21 14:07:39 UTC
I tried this in today's dev build, using introduce variable and change method parameters, and was unable to reproduce. Must have been fixed somewhere in the past 4 years :)
Comment 3 Jesse Glick 2013-05-21 14:46:48 UTC
Verified in 20130506-77c7571a74e2.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo