Bug 13292 - Recursion in AWT-EventQueue thread hangs/crashes NB
Recursion in AWT-EventQueue thread hangs/crashes NB
Status: CLOSED DUPLICATE of bug 11649
Product: ide
Classification: Unclassified
Component: UI
3.x
PC Windows ME/2000
: P1 (vote)
: 3.x
Assigned To: issues@www
issues@www
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-28 23:51 UTC by dmiller
Modified: 2005-03-09 04:28 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dmiller 2001-06-28 23:51:21 UTC
I am able to consistantly lock up NB 3.2.
Eventually, an out-of-memory exception is thrown.
(Presumably) since memory is exhausted, no stack trace is generated.
Once I could reproduce the hang, I was able to signal the
JVM to dump the thread stack. Such a dump is the origin of the 
following trace.

I am running in MDI mode with the Windows L&F.
Double clicking the Maximize button of the source viewer does this to the stack:

    "AWT-EventQueue-0" prio=7 tid=0x9c3450 nid=0x2a8 runnable [0x9993000..0x99bfdc4]
        at
sun.awt.windows.WGlobalCursorManager.findHeavyweightUnderCursor(Native Method)
        at sun.awt.GlobalCursorManager._updateCursor(GlobalCursorManager.java:182)
        at
sun.awt.GlobalCursorManager.updateCursorImmediately(GlobalCursorManager.java:91)
        at java.awt.Container.addImpl(Container.java:396)
        at javax.swing.JLayeredPane.addImpl(JLayeredPane.java:201)
        at java.awt.Container.add(Container.java:284)
        at javax.swing.JLayeredPane.setLayer(JLayeredPane.java:343)
        at javax.swing.JLayeredPane.setPosition(JLayeredPane.java:424)
        at javax.swing.JLayeredPane.moveToFront(JLayeredPane.java:395)
        at javax.swing.JInternalFrame.moveToFront(JInternalFrame.java:1024)
        at
javax.swing.DefaultDesktopManager.activateFrame(DefaultDesktopManager.java:207)
        at
com.sun.java.swing.plaf.windows.WindowsDesktopManager.activateFrame(WindowsDesktopManager.java:65)
        at
javax.swing.plaf.basic.BasicInternalFrameUI.activateFrame(BasicInternalFrameUI.java:624)
        at
javax.swing.plaf.basic.BasicInternalFrameUI$InternalFramePropertyChangeListener.propertyChange(BasicInternalFrameUI.java:433)
        at
javax.swing.event.SwingPropertyChangeSupport.firePropertyChange(SwingPropertyChangeSupport.java:153)
        at javax.swing.JComponent.firePropertyChange(JComponent.java:3721)
        at javax.swing.JInternalFrame.setSelected(JInternalFrame.java:966)
        at
javax.swing.DefaultDesktopManager.minimizeFrame(DefaultDesktopManager.java:103)
        at
javax.swing.plaf.basic.BasicInternalFrameUI.minimizeFrame(BasicInternalFrameUI.java:606)
        at
javax.swing.plaf.basic.BasicInternalFrameUI$InternalFramePropertyChangeListener.propertyChange(BasicInternalFrameUI.java:420)
        at
javax.swing.event.SwingPropertyChangeSupport.firePropertyChange(SwingPropertyChangeSupport.java:153)
        at javax.swing.JComponent.firePropertyChange(JComponent.java:3721)
        at javax.swing.JInternalFrame.setMaximum(JInternalFrame.java:890)
   
This sequence of calls is repeated until the stack gives out:

        at
org.netbeans.core.windows.frames.InternalFrameTypeImpl.setMaximum(InternalFrameTypeImpl.java:198)
        at
com.sun.java.swing.plaf.windows.WindowsDesktopManager.activateFrame(WindowsDesktopManager.java:76)
        at
javax.swing.plaf.basic.BasicInternalFrameUI.activateFrame(BasicInternalFrameUI.java:624)
        at
javax.swing.plaf.basic.BasicInternalFrameUI$InternalFramePropertyChangeListener.propertyChange(BasicInternalFrameUI.java:433)
        at
javax.swing.event.SwingPropertyChangeSupport.firePropertyChange(SwingPropertyChangeSupport.java:153)
        at javax.swing.JComponent.firePropertyChange(JComponent.java:3721)
        at javax.swing.JInternalFrame.setSelected(JInternalFrame.java:966)
        at
javax.swing.DefaultDesktopManager.maximizeFrame(DefaultDesktopManager.java:91)
        at
javax.swing.plaf.basic.BasicInternalFrameUI.maximizeFrame(BasicInternalFrameUI.java:600)
        at
javax.swing.plaf.basic.BasicInternalFrameUI$InternalFramePropertyChangeListener.propertyChange(BasicInternalFrameUI.java:416)
        at
javax.swing.event.SwingPropertyChangeSupport.firePropertyChange(SwingPropertyChangeSupport.java:153)
        at javax.swing.JComponent.firePropertyChange(JComponent.java:3721)
        at javax.swing.JInternalFrame.setMaximum(JInternalFrame.java:890)
Comment 1 Jan Zajicek 2001-06-29 09:28:37 UTC

*** This issue has been marked as a duplicate of 11649 ***
Comment 2 Quality Engineering 2003-07-01 15:17:32 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
Comment 3 Quality Engineering 2003-07-01 15:22:37 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo