Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 132857 - Welcome screen painting very slow when running on remote computer
Welcome screen painting very slow when running on remote computer
Status: VERIFIED FIXED
Product: ide
Classification: Unclassified
Component: Welcome
6.x
All Unix
: P2 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@ide
61fixes2-fixed
: PERFORMANCE
: 122451 124523 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-15 10:29 UTC by Pavel Flaska
Modified: 2008-07-24 16:44 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Flaska 2008-04-15 10:29:37 UTC
Steps:
1. Log on to another computer, e.g. using ssh,
2. run NetBeans with new user directory.

The window is grey for ages.

3. Uncheck the "Show On Startup",
4. close the welcome screen,
5. exit the IDE.

Re-run the IDE, main window is painted immediately.
Comment 1 Pavel Flaska 2008-04-15 10:31:56 UTC
Tomas observed the problem, cc'ing him.
Comment 2 Stanislav Aubrecht 2008-04-15 12:14:23 UTC
fixed in core-main - i enlarged the background images to decrease the count of paint operations

6a0e68846ce2
Comment 3 Pavel Flaska 2008-04-15 17:04:08 UTC
Verified. Thanks for immediate fix.
Comment 4 Stanislav Aubrecht 2008-04-24 16:46:07 UTC
i think this is a good candidate for some 6.1 patch...
Comment 5 Thomas Preisler 2008-05-02 20:05:35 UTC
Yes, can we please get the fix into patch 2?
Comment 6 Lukas Hasik 2008-05-03 20:51:55 UTC
marking as candidate for patch2
Comment 7 Stanislav Aubrecht 2008-05-05 17:53:49 UTC
*** Issue 124523 has been marked as a duplicate of this issue. ***
Comment 8 Thomas Preisler 2008-05-22 20:54:10 UTC
I just tried a trunk build and don't see an improvement (I assume proposed fix is now in a trunk build). Xhost'ing is
still virtually impossible due to the start page performance problem. If I manage to uncheck the "Show At Startup'
checkbox, the IDE displays *much* faster and is usable in an xhosted environment. 

I will reopen this issue. Has it really been fixed or am I looking at a wrong build?
Comment 9 Thomas Preisler 2008-05-22 20:56:02 UTC
Also marked this issue with SSIDE. It is important for SunStudio (which is based on 6.1) works in xhosted environments
which is more common in the Unix world.
Comment 10 ivan 2008-05-22 21:39:07 UTC
A ^\ shows that the AWT event thread is engaged in activity that usually requires
synchronous back and forth to the X server.

        at sun.java2d.loops.MaskBlit.MaskBlit(Native Method)
        at sun.java2d.loops.MaskBlit$General.MaskBlit(MaskBlit.java:201)
        - locked <0x48660640> (a sun.java2d.loops.MaskBlit$General)
        at sun.java2d.loops.Blit$GeneralMaskBlit.Blit(Blit.java:186)
        at sun.java2d.pipe.DrawImage.blitSurfaceData(DrawImage.java:821)
        at sun.java2d.pipe.DrawImage.renderImageCopy(DrawImage.java:444)
        at sun.java2d.pipe.DrawImage.copyImage(DrawImage.java:51)
        at sun.java2d.pipe.DrawImage.copyImage(DrawImage.java:876)
        at sun.java2d.SunGraphics2D.drawImage(SunGraphics2D.java:2847)
        at sun.java2d.SunGraphics2D.drawImage(SunGraphics2D.java:2832)
        at org.netbeans.modules.welcome.ui.Stripe.paintComponent(Stripe.java:82)

In the past the start page used anti-aliasing and that was one reason to use
masked blits, but I don't see any anti-aliased fonts on my start page.
Comment 11 Stanislav Aubrecht 2008-05-23 11:18:55 UTC
thp, what build did you reproduce this issue then?
Comment 12 Thomas Preisler 2008-05-23 16:36:00 UTC
I used:

netbeans-trunk-nightly-200805211202-cpp-solaris-x86.sh

which is a trunk build from 0521. It is supposed to have the fix, correct? I will be happy to try a different build ....
Comment 13 Stanislav Aubrecht 2008-05-27 12:47:00 UTC
i check the repository and the fix is there (it was a simple enlargement of images to be painted in the welcome screen)

can QA verify that this issue is really reproducible in the latest builds? thanks
Comment 14 Thomas Preisler 2008-05-28 05:08:12 UTC
We (Sun Studio) really wants this fixed and added to patch 2. Can QA please look at it?
Comment 15 Pavel Flaska 2008-05-28 09:39:03 UTC
I've tried in 20080528 custom build and I'm not able to reproduce.
Comment 16 Marian Mirilovic 2008-05-28 14:49:54 UTC
Lukas/Petr, 
could we verify the fix ? Thanks in advance.
Comment 17 Lukas Hasik 2008-05-28 15:14:53 UTC
We tested it with pflaska and we were not able to reproduce it with latest development build. We remotely connected from
Mac to linux machine. The repaint of remote IDE was slower than IDE on the same computer, of course. However the Welcome
Screen appeared in 3-4 seconds.

QE has marked this issue as patch2 candidate already. But what do you expect from us, thp? You (as the customer that
wants the fix) reported that the fix doesn't work for you. We think it has been fixed. What now? Could you provide a
measurement, could you profile, etc.? 

I'll test one more with almost the same setup but I need to know it.
1, what OS - of both machines
2, what window manager - on both machines
3, IDE = cpp
4, what jdk?
5, how exactly you run the IDE on the remote computer? (we ssh to the linux, run IDE that displayed back on Mac)
6, what internet connection do you use? I can imagine that using dial-up can be slow.
Comment 18 Thomas Preisler 2008-05-28 21:19:36 UTC
I tried another build: netbeans-trunk-nightly-200805281203-cpp.zip and now I cannot reproduce the problem either. It displays reasonable fast with or 
without start page. No explanation why I couldn't get it to work with the other build. I also tried a SunStudio build based on Netbeans-trunk-nightly-
200805281203-cpp.zip and it too displays start page reasonable fast when X hosted. I will close again.
Comment 19 Thomas Preisler 2008-05-28 21:23:35 UTC
Putting it back to VEIFIED
Comment 20 Lukas Hasik 2008-05-28 21:27:17 UTC
great, thank you.
Verified by me, pflaska and thp. The  issue willbe part of patch2 for NB 6.1
Comment 21 pgebauer 2008-05-30 19:05:28 UTC
The fix has been ported into the release61_fixes branch:

http://hg.netbeans.org/release61_fixes/rev/6e10f3f80e2e
Comment 22 ivan 2008-06-05 03:26:45 UTC
I too see that it is fixed in the trunk.
Comment 23 Thomas Preisler 2008-07-09 00:54:26 UTC
removing SSIDE keyword. Fix has been integrated into SS.
Comment 24 Stanislav Aubrecht 2008-07-24 16:44:14 UTC
*** Issue 122451 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo