Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 132721 - NullPointerException at org.openide.filesystems.FileUtil.toFile
NullPointerException at org.openide.filesystems.FileUtil.toFile
Status: VERIFIED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
All All
: P3 (vote)
: 6.x
Assigned To: J Bachorik
issues@profiler
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 75953 136614 154571 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-14 09:39 UTC by tboerkel
Modified: 2009-04-08 14:14 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (606 bytes, text/plain)
2008-04-14 09:39 UTC, tboerkel
Details
stacktrace (606 bytes, text/plain)
2008-06-01 01:52 UTC, tboerkel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tboerkel 2008-04-14 09:39:19 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) Client VM, 10.0-b19
OS: Windows XP, 5.1, x86

User Comments: 
Integrating Profiler with project.
Comment 1 tboerkel 2008-04-14 09:39:24 UTC
Created attachment 60111 [details]
stacktrace
Comment 2 Antonin Nebuzelsky 2008-04-15 17:14:11 UTC
Reassigning to new module owner jskrivanek.
Comment 3 tboerkel 2008-06-01 01:52:13 UTC
Created attachment 62215 [details]
stacktrace
Comment 4 Exceptions Reporter 2008-06-09 16:35:49 UTC
This issue has already 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=35612
Comment 5 J Bachorik 2008-07-14 11:43:52 UTC
Profiler integration relies on a specific name of your ant build file. Namely, it tries to find "build.xml".
Problem is that for Java projects with existing sources the build file name is fully customizable. Due to this the
profiler will have to recognize this situation and search for the custom build file instead of the default one.
Comment 6 Quality Engineering 2008-07-17 04:33:43 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #324 build
Changeset: http://hg.netbeans.org/main/rev/3d7f314ef2b7
User: Jarslav Bachorik <yardus@netbeans.org>
Log: #132721 - NPE while integrating profiler with a project with existing sources
Comment 7 J Bachorik 2008-07-17 07:24:58 UTC
fixed
Comment 8 J Bachorik 2008-08-28 11:01:39 UTC
*** Issue 136614 has been marked as a duplicate of this issue. ***
Comment 9 J Bachorik 2008-12-04 11:52:58 UTC
*** Issue 154571 has been marked as a duplicate of this issue. ***
Comment 10 J Bachorik 2008-12-04 11:58:18 UTC
See issue #136614
The problem was not fully fixed - the profiler correctly modifies the custom build file but it still tries to use the
hard-wired "build.xml" when profiling is started.
Comment 11 J Bachorik 2008-12-04 12:05:09 UTC
It's fully fixed now : http://hg.netbeans.org/profiler-main/rev/05aea724a0ef

The workaround for a time being would be not to use the folder with the existing build script as a new project directory
- which should be a recommended approach anyway.
Comment 12 J Bachorik 2008-12-04 12:07:03 UTC
*** Issue 75953 has been marked as a duplicate of this issue. ***
Comment 13 J Bachorik 2008-12-04 12:54:18 UTC
The correct changeset for fixes is http://hg.netbeans.org/profiler-main/rev/901c6f4dcb70
Comment 14 J Bachorik 2008-12-04 16:39:56 UTC
one last update - due to problems with the local hg repository I had to rollback the fix and reintroduce it in
http://hg.netbeans.org/profiler-main/rev/de061552d2b7
Comment 15 Quality Engineering 2008-12-09 18:35:18 UTC
Integrated into 'main-golden', will be available in build *200812091520* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/05aea724a0ef
User: Jaroslav Bachorik <yardus@netbeans.org>
Log: #132721 - custom ant build script name support
Comment 16 Rashid Urusov 2008-12-19 11:19:33 UTC
VERIFIED in build 200812180001
Comment 17 pgebauer 2009-01-05 17:22:16 UTC
Could you please state what the correct changeset to port to the release65_fixes branch is? There are three possible changesets 05aea724a0ef, 901c6f4dcb70 and de061552d2b7 in descriptions. Should they be applied all one by one? Or should just the last one be applied and the remaining two 
changesets could be apprehended as mistakes?
Comment 18 J Bachorik 2009-01-06 08:24:32 UTC
The correct changeset to apply is de061552d2b7.
Comment 19 pgebauer 2009-01-06 10:19:02 UTC
The fix has been ported into the release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/c36c5b9eb772
Comment 20 pgebauer 2009-01-15 21:28:23 UTC
The changes are in eager modules (org.netbeans.modules.profiler.j2ee and org.netbeans.modules.profiler.j2se). Even though the specification versions were 
incremented for both of them, they are not updated by plugin manager during update. In other words, the fix isn't deliverable via a patch. It seems to be a 
bug in the plugin manager.

The issue has been rolled back from the release65_fixes branch (http://hg.netbeans.org/release65_fixes/rev/c74c8b261099). Now, it is the 65patch3 
candidate.

Comment 21 pgebauer 2009-04-08 14:14:02 UTC
The status whiteboard "65fixes4-candidate" has been removed.
At this time our proactive patches for the NetBeans 6.5.x IDE have concluded.

If you own a Sun service plan contract for NetBeans, you may wish to contact
Sun Service http://www.sun.com/contact/support.jsp to request a fix via the
product defect escalation process.

For more information on purchasing a Sun service plan contract for NetBeans,
refer to the service plan item "Sun Software Service Plans (S3P) for Developers"
in the Sun Service table found on our NetBeans Support Resources
page http://www.netbeans.org/kb/support.html


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo