Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 132590 - Documents do not become unmodified after undo
Documents do not become unmodified after undo
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Key bindings
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Miloslav Metelka
issues@editor
61fixes1-fixed
: REGRESSION
: 132843 133069 133466 135114 135289 135729 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-11 03:28 UTC by Jesse Glick
Modified: 2008-06-04 08:40 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2008-04-11 03:28:54 UTC
Sometime recently, pressing Ctrl-Z ceased to suffice to make a buffer be marked unmodified, even after undoing all edits
since it was opened.
Comment 1 Antonin Nebuzelsky 2008-04-16 09:50:10 UTC
Marku, please evaluate.
Comment 2 mslama 2008-04-17 10:31:56 UTC
Confirmed.
Comment 3 mslama 2008-04-17 17:03:01 UTC
This is weird bug introduced by 77085:8982ded63389. Then it was fixed by next rev 77086:7a389aaba281. Then again it was
introduced by 77100:c9c1a766cf3f and stayed there till now.

I checked only limited set of revisions because I must get revision, build IDE and run IDE to see if bug is there or
not.  It means that this transition map need not be complete. It is possible that this is caused by recent repository
break. This happened around 2 Apr. I think this should be fixed by someone who known editor code. From diffs it looks
like change in editor/src and editor.lib/src.

It would be good to consider higher modularity of repository so that one 'helper' cannot make so big harm. CCing Michal.
Comment 4 mslama 2008-04-17 17:11:46 UTC
I just checked and this issue is also in latest NB 6.1 build 6.1rc2-200804170002.
Comment 5 mslama 2008-04-17 18:27:26 UTC
Ok. I understand repo order better now. This issue is regression caused by:
changeset:   77082:4a5981146d70
user:        Miloslav Metelka <mmetelka@netbeans.org>
date:        Wed Apr 02 18:21:49 2008 +0200
summary:     #118038 - Undo key binding not working in Java Editor.

Always reproducible with txt file. Open it in editor write any letter and press Ctrl-Z (Undo). Editor stays modified.
Comment 6 Miloslav Metelka 2008-04-17 21:07:46 UTC
I will fix this.
Comment 7 Marian Mirilovic 2008-04-18 08:04:35 UTC
Ok Mila, please fix in trunk as soon as possible, we'll add this issue into the list for patch 1
Comment 8 Jiri Prox 2008-04-18 12:16:15 UTC
*** Issue 132843 has been marked as a duplicate of this issue. ***
Comment 9 Jiri Prox 2008-04-18 12:48:17 UTC
*** Issue 133069 has been marked as a duplicate of this issue. ***
Comment 10 Jiri Prox 2008-04-22 07:36:58 UTC
*** Issue 133466 has been marked as a duplicate of this issue. ***
Comment 11 Miloslav Metelka 2008-04-22 12:19:00 UTC
http://hg.netbeans.org/main/rev/1c1949f0a731
Comment 12 Jiri Prox 2008-04-23 10:07:14 UTC
verified in trunk
Comment 13 pgebauer 2008-04-27 19:59:22 UTC
The fix has been ported into the release61_fixes branch:

http://hg.netbeans.org/release61_fixes/rev/86f85e0703df
Comment 14 Jiri Prox 2008-05-15 09:25:53 UTC
*** Issue 135114 has been marked as a duplicate of this issue. ***
Comment 15 Jiri Prox 2008-05-19 08:51:57 UTC
*** Issue 135289 has been marked as a duplicate of this issue. ***
Comment 16 Petr Dvorak 2008-05-23 19:13:35 UTC
*** Issue 135729 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo