Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 132513 - Cant' add valid J2EE modules as Library in Enterprise app
Cant' add valid J2EE modules as Library in Enterprise app
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: EAR
6.x
All All
: P2 (vote)
: 6.x
Assigned To: David Konecny
issues@javaee
61fixes1-fixed
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-10 12:32 UTC by Petr Blaha
Modified: 2008-06-04 08:35 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Blaha 2008-04-10 12:32:21 UTC
[NB 6.1 RC1]
Steps:

1) create web project and build it
2) create new Enterprise application 
3) go to project properties -> packaging and click to Add Jar/Folder

You can not choose *.war there. I think that user should be able to choose all valid J2EE modules that are *.war, *.rar
on this dialog.
Comment 1 David Konecny 2008-04-11 08:20:17 UTC
Regression caused by earproject refactorings during sharable libraries implementation.

Temporarily workaround: see issue 132431

Fix is simple and should be straightforward to integrate to 6.1 or patch release.

http://hg.netbeans.org/main?cmd=changeset;node=2af1bc17bd9e
Comment 2 Dan Kolar 2008-04-14 14:27:11 UTC
v. in trunk
Comment 3 pslechta 2008-04-28 18:14:56 UTC
The fix has been ported into the release61_fixes branch.

http://hg.netbeans.org/release61_fixes/rev/66f52f685cca


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo