Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 132507 - Step Into execution does not point to the first executed statement
Step Into execution does not point to the first executed statement
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Debugger
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Alexey Butenko
issues@javafx
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-10 12:04 UTC by Alexandr Scherbatiy
Modified: 2008-08-22 12:00 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Scherbatiy 2008-04-10 12:04:53 UTC
Steps to reproduce:

- Create an FX file:
-----------------------------------------------------------------------
import java.lang.System;

function a(){
    System.out.println("a");
}

function b(){
    System.out.println("b");
    a();
}

function c() {
    System.out.println("c");
    b();
}

function d(){}

c();
-----------------------------------------------------------------------

- Press 'F7' (Step Into)
  Current Program Counter points to 'function d(){}' line
  not to 'c();' that is the first executed statement.
Comment 1 Alexey Butenko 2008-04-23 12:49:26 UTC
process exist because not defined onClose operation for Frames.
In Java for Frames there is setDefaultCloseOperation used automatically, the same functionality should be implemented in JavaFX.
Comment 2 Alexey Butenko 2008-04-23 13:12:07 UTC
Please ignore my last comment, it was for issue #122157, sorry
Comment 3 Alexandr Scherbatiy 2008-05-23 09:03:18 UTC
The same is for the following code:
-----------------------------------------------------
var a = 10;
var b = 20;
var c = a + b;
var d = a - b;
-----------------------------------------------------
Comment 4 Alexey Butenko 2008-07-09 16:06:45 UTC
mark as fixed, please verify
Comment 5 Alexandr Scherbatiy 2008-07-10 14:05:27 UTC
'F7' (Step Into) runs 2 debugger and starts from the last line in the code
Comment 6 Alexey Butenko 2008-08-13 10:30:13 UTC
F7 disabled, please verify
Comment 7 Alexandr Scherbatiy 2008-08-22 12:00:40 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo