Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 132450 - Missing comma in comma separated parameters after RE
Missing comma in comma separated parameters after RE
Status: VERIFIED FIXED
Product: uml
Classification: Unclassified
Component: Reverse Engineering
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Viktor Lapitski
issues@uml
61fixes1-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 18:23 UTC by Joanne Lau
Modified: 2008-06-04 08:39 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joanne Lau 2008-04-09 18:23:28 UTC
Build: 200804081109

Steps:

 1) Reverse engineer following code to UML project
     public class DoublePrimitiveType  {  
       double  friendlyInitializedMember  = Math.max( 4.5 , 5.5 );

     }
 2) And invoke "generate dependency diagram" on the DoublePrimitiveType class
   
    Attribute displayed in the class element :
      package double friendlyInitializedMember = Math.max (4.55.5)

    Notice the missing comma between the 2 numbers
Comment 1 Peter Lam 2008-04-09 23:51:56 UTC
looks like a p2 issue here. upgraded to p2.
Comment 2 Peter Lam 2008-04-10 00:33:26 UTC
This issue is similar to issue 126586 that was fixed in 6.1.
And the problem is not just in the double primitive type, same to type int, float, String, etc as these below. Looks
like the problem occurs on comma separated parameters.

public class PrimitiveType {
    float val1 = 4;
    double max1  = Math.max( 4.5 , 5.5 );
    int max2  = Math.max( 4 , 5 );
    float max3  = Math.max( val1 , 5 );
    int sum = getSum(4, 5, 6);
    String str = conCat("this", "is", "string call");
    
    public int getSum(int p1, int p2, int p3) {
        return p1 + p2 + p3;
    }
    
    public String conCat(String s1, String s2, String s3) {
        return s1 + s2 + s3;
    }
}
Comment 3 Viktor Lapitski 2008-04-19 06:46:32 UTC
Fixed.

author	lvv@netbeans.org
	Fri Apr 18 22:41:20 2008 -0700 (22 seconds ago)
changeset 78685	0a49a64f2d67
parent 78684	9ef5cbc4f644
Fix for 132450 Missing comma in comma separated parameters after RE 

and 

author	lvv@netbeans.org
	Fri Apr 18 22:45:59 2008 -0700 (19 seconds ago)
changeset 71444	0843b2c82c42
parent 71443	aff12c9b271e
Fix for 132450 Missing comma in comma separated parameters after RE 
Comment 4 Joanne Lau 2008-04-22 18:19:27 UTC
Fix verified in trunk build 20080421151521
Comment 5 pslechta 2008-05-06 17:27:01 UTC
lvv, please clarify where you did push your changesets!

I found the first one: http://hg.netbeans.org/main/rev/0a49a64f2d67

But cannot find the second one. Neither http://hg.netbeans.org/main/rev/0843b2c82c42 nor
http://hg.netbeans.org/release61/rev/0843b2c82c42 is working...
Comment 6 Viktor Lapitski 2008-05-07 06:01:45 UTC
the second chanset is just a double integration into another branch (ie. repository).
Comment 7 pslechta 2008-05-07 08:47:50 UTC
The fix has been ported into the release61_fixes branch.

http://hg.netbeans.org/release61_fixes/rev/57976190eef7


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo