Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 132420 - XML code-completion only works on first element
XML code-completion only works on first element
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: Schema
6.x
All All
: P2 with 2 votes (vote)
: 6.x
Assigned To: Samaresh Panda
issues@xml
http://www.netbeans.org/servlets/Read...
61fixes2-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 15:27 UTC by _ hair
Modified: 2008-07-10 15:14 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
jar file (199.75 KB, application/octet-stream)
2008-04-10 04:04 UTC, Samaresh Panda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ hair 2008-04-09 15:27:32 UTC
Using nb6.1 i only get code-completion on the first element in the xml
editor.

My xml file seems to declare the schema correctly:

<modes xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:noNamespaceSchemaLocation="modes.xsd">

    <mode id="default-empty-mode" executor="parallel" analysis="false">
    </mode>

    <mode id="default-mode" executor="parallel" analysis="false">
        <command ...


The schema is loaded correctly as i get code-completion w/ all the xsd
documentation in <|mode

But i get "no suggestions" for attributes on the <mode> element and if i
put the cursor in <|command or any other child element of <mode>.

Funny enough i also get "no suggestions" in </modes but i do get code-
completion and documentation on attributes for <modes>.

The mode.xsd seems correct since manual xml validation works ok.

My modes.xml:
http://sesat.no/svn/sesat-kernel/trunk/generic.sesam/war/src/main/conf/modes.xml

My modes.xsd:
http://sesat.no/tmp/modes.xsd
Comment 1 Samaresh Panda 2008-04-09 17:38:11 UTC
Let me investigate.
Comment 2 Samaresh Panda 2008-04-09 23:57:22 UTC
*** Issue 132452 has been marked as a duplicate of this issue. ***
Comment 3 Samaresh Panda 2008-04-10 04:02:41 UTC
Fix integrated: http://hg.netbeans.org/main/rev/2fc7dc80305e.
If you cannot wait for the fix, please use the attached jar file; copy it to <NBHOME>/ide9/modules.

As per iteam, marking this as a patch1 candidate. This fix will be delivered as a patch on top of NB6.1.
Comment 4 Samaresh Panda 2008-04-10 04:04:10 UTC
Created attachment 59945 [details]
jar file
Comment 5 _ hair 2008-04-10 09:39:09 UTC
works a charm.thanks samaresh for a quick fix!
Comment 6 rbalada 2008-04-29 13:32:34 UTC
I've backported the changeset http://hg.netbeans.org/main/rev/2fc7dc80305e into release61_fixes repository as
http://hg.netbeans.org/release61_fixes/rev/eb186baf479d

changeset:   77487:eb186baf479d
tag:         tip
user:        samaresh@netbeans.org
date:        Wed Apr 09 21:42:49 2008 -0500
summary:     Issue 132420: XML code-completion only works on first element.
Comment 7 pgebauer 2008-05-15 22:00:32 UTC
There is a problem to update org.netbeans.modules.xml.schema.completion.nbm from UC. The fix delivery has been moved to
patch2.
Comment 8 tonybeckham 2008-06-19 22:16:41 UTC
I don't see this as fixed in Patch 2.
Comment 9 tonybeckham 2008-06-20 20:26:32 UTC
I tested again, looks like I didn't have correct setup of patch2 installation.  This *IS* working in patch 2.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo