Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 132362 - I18N - XML Schema Design View has square boxes instead of Japanese characters
I18N - XML Schema Design View has square boxes instead of Japanese characters
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: Schema
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: Samaresh Panda
issues@xml
61fixes1-fixed
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 19:55 UTC by kaa
Modified: 2008-06-04 08:45 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
image (94.65 KB, image/jpeg)
2008-04-08 19:57 UTC, kaa
Details
Design view (800.38 KB, application/octet-stream)
2008-04-10 00:56 UTC, Samaresh Panda
Details
new fix (811.69 KB, application/octet-stream)
2008-04-15 20:27 UTC, Samaresh Panda
Details
image (71.21 KB, image/jpeg)
2008-04-21 19:35 UTC, kaa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaa 2008-04-08 19:55:47 UTC
Product Version: NetBeans IDE Dev (Build 200804060802)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; MS932; ja_JP (nb)
font size 16

Steps:
1. Create BPEL Module
2. Add XML Schema
3. Open it and switch to the Design view

There are square boxes instead of Japanese characters. See image.
Correct Japanese characters are circled in blue. I'm running in the Japan locale, using a pseudo localized Netbeans.
Comment 1 kaa 2008-04-08 19:57:10 UTC
Created attachment 59861 [details]
image
Comment 2 kaa 2008-04-08 20:00:38 UTC
It looks the similar with 131833.
Reproducible on WinXP in ja_JP locale. Project encodings UTF-8 and Win-31j.
Comment 3 Samaresh Panda 2008-04-08 20:05:42 UTC
Was it ever tested with Ja locale or you're testing this very first time?
Comment 4 Ken Frank 2008-04-08 20:11:27 UTC
are you using the trunk build that has final fix to 131833.

if not this might be an not valid issue.

and I'm not aware of providing pseudo localization for a build that has the fix
so not sure how this might be valid issue at this point since build you are using
still has the 131833.

see that issue for what build to use and find out which jar files need to
be pseudo localized to show just this problem.

also this issue does not tell if ide run with --fontsize option or not and behavior
in each case.

I am marking as incomplete, remove keyword when provided information is obtained
and update issue or close if fixed as part of other issue fix.

ken.frank@sun.com
Comment 5 Erno Mononen 2008-04-09 08:08:04 UTC
I think this module does not use xml/multiview, so the fix for issue 131833 did not fix this. The problem is caused by
using a particular font face when creating fonts, e.g. :

new Font(font.getFontName() .. )

Replacing those usages in the code should fix this, similarly as in issue 131833.
Comment 6 kaa 2008-04-09 14:50:21 UTC
I didn't use trunk build. I used netbeans-6.1rc1-200804060802 with pseudo bundle 0406.
Checked in trunk build 0408 with and without font size option:
The fix for 131833 exists there but the problem with xsd file is also present.
This issue looks close to the 131833 but I couldn't assume that they have the same fixes.

At the begging of the description I mentioned that font size was 16.
The issue is also reproducible without this option using default value.
  


Comment 7 Samaresh Panda 2008-04-09 15:42:58 UTC
This is not a P1 and arrived after the cut-off for P2s. Does it have to be fixed for 6.1?
Comment 8 Ken Frank 2008-04-09 16:07:42 UTC
I think it should since 131833 with similar problems was
but only if the fix is very low impact and won't have 
possibility of effecting anything else, especially
about other font situations as to them not displaying ok.

the reason is that, to user using translated nb, assumption is that
they dont know english, and if they see the square boxes, they
won't know what it says.

ken.frank@sun.com
Comment 9 Samaresh Panda 2008-04-10 00:42:49 UTC
I'm afraid there is nothing for me to fix. We have three MV descriptions Source, Schema and Design (that implements
MultiViewDescription) and they return "Source", "Schema" and "Design" as their display names.

These are set in org.netbeans.core.multiview.TabsComponent.java, line 212-213.

        Mnemonics.setLocalizedText(button, description.getDisplayName());
        button.setModel(new TabsButtonModel(description));

I think it needs to be fixed there. CC'ing Milos for his take.

But I have to ask again, why was this not an issue before and surfaced just yesterday. This part of the code was not
touched for years. Schema/Design view used to exist in 6.0 as well. Was 6.0 not tested with Ja locale?
Comment 10 Samaresh Panda 2008-04-10 00:47:59 UTC
Sorry ignore my last comment, I looked at the wrong code.
Comment 11 Samaresh Panda 2008-04-10 00:56:32 UTC
Created attachment 59940 [details]
Design view
Comment 12 Samaresh Panda 2008-04-10 00:57:11 UTC
Ken, please try the new jar and let me know if the fix helps.
Comment 13 Samaresh Panda 2008-04-10 00:57:46 UTC
I mean copy the jar to <NB>/xml2/modules.
Comment 14 Ken Frank 2008-04-10 02:46:08 UTC
can I use previous pseudo localized
jars for this test - that is,
fix is just to code, not to messages ?

ken.frank@sun.com
Comment 15 Ken Frank 2008-04-10 03:18:06 UTC
I used a trunk build of 0406 and replaced the attached jar, but
it did not help.

I ran using --fontsize option and not --fontsize option

is it needed to use a more recent trunk or 6.1 build to do this ?

ken.frank@sun.com
Comment 16 Samaresh Panda 2008-04-10 14:56:57 UTC
Let me look into this...
Comment 17 Ken Frank 2008-04-14 22:41:48 UTC
can this be fixed in trunk soon so it can go into first 6.1 patch ? that seems
to be requirement that it be fixed in trunk first.
I added the status whiteboard word here also.

ken.frank@sun.com
Comment 18 Samaresh Panda 2008-04-15 20:27:16 UTC
Created attachment 60231 [details]
new fix
Comment 19 Samaresh Panda 2008-04-15 20:30:13 UTC
Ken, please try the new jar before you have a build for this fix. I'll commit this in the mean while.
Comment 20 Samaresh Panda 2008-04-15 20:31:50 UTC
Fix integrated: http://hg.netbeans.org/main/rev/9786773b4f26.
Comment 21 Ken Frank 2008-04-15 21:32:12 UTC
looks ok using attached jar using recent 0406 6.1

started ide with --fontsize option and not with it

question - might this fix have any impact on any other ui parts of xml or other areas ?
that is, what other ui objects/labels/etc are affected by this - we want to make
sure they look ok too

finally, we will verify it in trunk soon as well and mark verified there.

ken.frank@sun.com
Comment 22 Samaresh Panda 2008-04-15 21:35:46 UTC
It'll only affect design view.
Comment 23 kaa 2008-04-21 19:29:06 UTC
checked in trunk build:

Product Version: NetBeans IDE Dev (Build 200804210001)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; MS932; ja_JP (nb)
Comment 24 kaa 2008-04-21 19:35:00 UTC
Created attachment 60513 [details]
image
Comment 25 kaa 2008-04-22 16:12:06 UTC
The fix needs to be in release61 branch to be able to be in patch.
Please put it there after final 6.1 fcs.
Comment 26 Ken Frank 2008-04-22 16:25:56 UTC
Andrey,

put info here about newly found 133517 
since it seems this has appeared only since
fix for this issue ?

ken.frank@sun.com
Comment 27 kaa 2008-04-23 15:36:58 UTC
Probably, the fix has side effect:
Multibyte chars in names of the Palette elements are shown with square boxes.
See issue 133517.
Comment 28 Erno Mononen 2008-04-23 16:13:14 UTC
Not necessarily a side effect, there still seem to be a few places in the xml/schema/abe module where a font is created 
using a particular font face. I did not look at those usages in detail though, just did a quick grep search in the 
module.
Comment 29 Ken Frank 2008-04-23 16:31:07 UTC
Erno,

since I think the fix for these kind of situations is known and not a lot of
code, could the fix for 133517 and others situations
in these modules that you found be fixed
for the first patch, since it means in these
cases either translated messages/labels
or users own use of multibyte would show as boxes,
and user would not know what is there ?

I'll add this info to the other issue.


ken.frank@sun.com
Comment 30 rbalada 2008-04-29 13:20:37 UTC
I've transplanted the changeset http://hg.netbeans.org/main/rev/9786773b4f26 into release61_fixes repository as
http://hg.netbeans.org/release61_fixes/rev/fa56cda1c5b0

changeset:   77484:fa56cda1c5b0
user:        samaresh@netbeans.org
date:        Tue Apr 15 14:25:22 2008 -0500
summary:     issue 132362: I18N square boxes in DV with Ja locale
Comment 31 kaa 2008-05-20 16:49:45 UTC
rechecked with fcs build and patch1.
The fix looks ok with default and 16 fontsize.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo