Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 132348 - I18N - wsdl from db wizard does not resize to show its text label
I18N - wsdl from db wizard does not resize to show its text label
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: SQL Project
6.x
All All
: P2 (vote)
: TBD
Assigned To: Pavan Veeravarapu
issues@soa
61fixes1-fixed
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 17:13 UTC by kaa
Modified: 2008-06-04 08:45 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
image (61.71 KB, image/jpeg)
2008-04-08 17:14 UTC, kaa
Details
the same panel at font 20 (45.12 KB, text/plain)
2008-04-18 07:34 UTC, nav064
Details
jpeg image. previous attachment was uploaded as text by mistake. (45.12 KB, image/jpeg)
2008-04-18 07:39 UTC, nav064
Details
image (58.92 KB, image/jpeg)
2008-04-21 18:33 UTC, kaa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaa 2008-04-08 17:13:53 UTC
Product Version: NetBeans IDE Dev (Build 200804060802)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; MS932; ja_JP(nb)
font size 16

1. Create SQL or BPEL Module
2. Open file new wizard: SOA -> WSDL From Database
3. Follow the wizard until step 5.

The wizard does not resize to show text: JNDI Name
I'm running in the Japan locale, using a pseudo localized Netbeans.

Assumption is that user does not need to manually resize most windows or dialogs to see all of the UI objects and
information in them. I'm running in pseudo localized locale in which each message/label is sometimes longer than in
English. To account for that in some locales, translations from English (and some other euro languages) could be shown
with longer strings.

Also I'm running at font size 16, which is viewed as a valid font size that might be used. Resizing issues are not just
related to i18n; they might show to user in English locale if they run at larger font size.

Often, these issues happen because the length of some label or message or size of entire window is hardcoded vs using
layout managers or other techniques or api to have the windows or the objects in them, dynamically resize. Sometimes,
embedding components in a scroll pane will solve the problem.
Comment 1 kaa 2008-04-08 17:14:32 UTC
Created attachment 59852 [details]
image
Comment 2 Venkat Srinivasan 2008-04-08 18:03:03 UTC
Pls look into this.
Comment 3 Ken Frank 2008-04-14 22:45:23 UTC
please provide fix in trunk soon since it needs to be verified
there before it can be in first 6.1 patch.

ken.frank@sun.com
Comment 4 nav064 2008-04-18 07:34:06 UTC
Created attachment 60386 [details]
the same panel at font 20
Comment 5 nav064 2008-04-18 07:37:11 UTC
I tried viewing the same at font size 20 in english locale and it is appearing properly. jpeg attached. Could this be
tested with the latest build? After Apr 18, 2008.
Comment 6 nav064 2008-04-18 07:39:42 UTC
Created attachment 60387 [details]
jpeg image. previous attachment was uploaded as text by mistake.
Comment 7 nav064 2008-04-18 09:38:37 UTC
Fix available on build #1659 or later
Comment 8 nav064 2008-04-21 06:59:55 UTC
Issues 120901,132348,132349,108973 - I18N changes jdbc bc wizard
HG: user: Nav  <nav064@netbeans.org>
HG: branch default
HG: changed sql.project/src/org/netbeans/modules/sql/project/ui/wizards/PanelProjectLocationVisual.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/builder/xsd/XSDGenerator.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/Bundle.properties
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/ChosenColumnPanel.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/InsertColumnPanel.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/JDBCWizardSelectionPanel.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/JDBCWizardTablePanel.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/JNDINamePanel.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/PolledColumnPanel.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/SimpleTargetChooserPanelGUI.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/UpdateColumnPanel.java

default branch: release61
Comment 9 kaa 2008-04-21 18:33:10 UTC
reproducible in trunk build:

Product Version: NetBeans IDE Dev (Build 200804210001)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; MS932; ja_JP (nb)
Comment 10 kaa 2008-04-21 18:33:45 UTC
Created attachment 60507 [details]
image
Comment 12 kaa 2008-04-22 18:04:01 UTC
verified in trunk build 1693 using org-netbeans-modules-sql-wizard_ja.jar
The message looks ok with --fontsize 16 option.
Comment 13 kaa 2008-04-22 18:04:40 UTC
v
Comment 14 pslechta 2008-04-28 17:46:40 UTC
The fix has been ported into the release61_fixes branch.

http://hg.netbeans.org/release61_fixes/rev/eeb2702b5087


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo