Bug 132285 - java.util.EmptyStackException at java.util.Stack.peek
java.util.EmptyStackException at java.util.Stack.peek
Status: RESOLVED FIXED
Product: javascript
Classification: Unclassified
Component: Editor
6.x
All All
: P1 (vote)
: 6.x
Assigned To: martin_adamek
issues@javascript
http://statistics.netbeans.org/except...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 08:15 UTC by Martin Schovanek
Modified: 2009-02-27 14:26 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Schovanek 2008-04-08 08:15:55 UTC
Build: NetBeans IDE Dev (Build 080408)
VM: Java HotSpot(TM) Client VM, 1.5.0_13-119, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_13-b05-237
OS: Mac OS X, 10.5.2, i386

User comments:
--------------
Just want to reformat ext-all.js or ext-all-debug.js
See: http://www.extjs.com/


STACKTRACE: (first 10 lines)
java.util.EmptyStackException
        at java.util.Stack.peek(Stack.java:79)
        at java.util.Stack.pop(Stack.java:61)
        at org.netbeans.modules.javascript.editing.JsPretty.decrease(JsPretty.java:589)
        at org.netbeans.modules.javascript.editing.JsPretty.decreaseContinuation(JsPretty.java:621)
        at org.netbeans.modules.javascript.editing.JsPretty.visitContinuation(JsPretty.java:202)
        at org.netbeans.modules.javascript.editing.JsPretty.walk(JsPretty.java:130)
        at org.netbeans.modules.javascript.editing.JsPretty.visitDefault(JsPretty.java:186)
        at org.netbeans.modules.javascript.editing.JsPretty.walk(JsPretty.java:154)
        at org.netbeans.modules.javascript.editing.JsPretty.format(JsPretty.java:93)
        at org.netbeans.modules.javascript.editing.JsFormatter.reformat(JsFormatter.java:124)
Comment 1 martin_adamek 2008-04-08 10:14:02 UTC
Fixed.
http://hg.netbeans.org/main/rev/b548ad527c9a
Comment 2 Martin Schovanek 2008-04-08 11:36:57 UTC
TM => Dev.
Comment 3 polan 2008-06-13 14:53:04 UTC
Verified.
Comment 4 Exceptions Reporter 2008-10-21 00:50:17 UTC
Reopening - reproduced in NetBeans IDE Dev (Build 200810181401)
http://statistics.netbeans.org/exceptions/detail.do?id=131260
Comment 5 martin_adamek 2008-10-21 11:46:48 UTC
I can't reproduce this. Anyway, I made fix in main repository in the problematic part with some logging.
http://hg.netbeans.org/main/rev/d0a1fcceefa5
Comment 6 Martin Schovanek 2008-10-21 15:24:34 UTC
Verified in trunk build by QE.
Comment 7 Quality Engineering 2008-10-21 15:45:07 UTC
Integrated into 'main-golden', will be available in build *200810211401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/d0a1fcceefa5
User: Martin Adamek <martin_adamek@netbeans.org>
Log: #132285: java.util.EmptyStackException at java.util.Stack.peek
Comment 8 Petr Blaha 2008-10-24 09:19:18 UTC
Please, push the fix in release65 clone. We would like to start new RC2 build today afternoon. Thanks
Comment 9 Martin Schovanek 2008-10-24 10:16:52 UTC
Integrated into release65 as:
http://hg.netbeans.org/release65/rev/626c26149a58
Comment 10 Martin Schovanek 2008-10-24 10:55:44 UTC
Fixed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo