Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 132273 - I18N - some words not from localized bundle files in wsdl from db wizard
I18N - some words not from localized bundle files in wsdl from db wizard
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: SQL Project
6.x
Sun All
: P2 (vote)
: TBD
Assigned To: Pavan Veeravarapu
issues@soa
61fixes1-fixed
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 01:47 UTC by Ken Frank
Modified: 2008-06-04 08:45 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
image (31.13 KB, image/gif)
2008-04-08 01:50 UTC, Ken Frank
Details
image (81.70 KB, image/jpeg)
2008-04-24 19:49 UTC, kaa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2008-04-08 01:47:54 UTC
is this correct cat/subcat - the messages in the wsdl from db wizard
are from jdbc or sql jar files ?

running 0406 6.1 build, in ja locale using pseudo localized nb.

create sql project or bpel project then wsdl from db file type -
in select operation specific attributes, click on the word Advanced -
the columns window comes up.

if the module that has these is org-netbeans-modules-sql-wizard
then I dont think the words are in bundle file of it.

1. word Advanced on the wizard
2. button labels on cols window
Select All, Clear All, OK, Cancel.



see attached gif
Comment 1 Ken Frank 2008-04-08 01:50:36 UTC
Created attachment 59803 [details]
image
Comment 2 Ken Frank 2008-04-08 02:24:55 UTC
marked as p1 since its about missing messages, needed for translated netbeans.

ken.frank@sun.com
Comment 3 Ken Frank 2008-04-08 02:29:10 UTC
moved to this categ/subcat - is it correct ?
Comment 4 Venkat Srinivasan 2008-04-08 07:35:43 UTC
Pls look into this.
Comment 5 Petr Blaha 2008-04-08 15:30:02 UTC
I saw the notification to reviewers mailing list. Please, fix the bug in trunk and Ken can verify it.
Comment 6 Petr Blaha 2008-04-09 14:53:04 UTC
See Bug Priority Guidelines: http://qa.netbeans.org/bugzilla/bug_priority_guidelines.html. For user using localized
release, if a message or label that come from the product does not come from a localized file is P2.
Comment 7 Ken Frank 2008-04-10 17:47:34 UTC
let me know when fix is in trunk and exact time of fix so we can get
correct trunk build and verify it, so then it can go to release 61 as
per process.

also tell me which product jar file(s) has the code and new messaages
in bundle files that are related to this fix.

ken.frank@sun.com
Comment 8 Ken Frank 2008-04-14 22:47:03 UTC
please fix in trunk soon since it needs to be verified there before it 
goes into first 6.1 patch, and since it is about missing messages,
it should go into that patch if at all possible.

ken.frank@sun.com
Comment 9 Ken Frank 2008-04-16 20:40:55 UTC
added the status whiteboard entry for issues that could be in
patch 1 for nb6.1

ken.frank@sun.com
Comment 10 nav064 2008-04-18 09:40:45 UTC
Fix available on trunk build #1659 or later. 
Comment 11 nav064 2008-04-21 06:57:18 UTC
Issues 120901,132348,132349,108973 - I18N changes jdbc bc wizard
HG: user: Nav  <nav064@netbeans.org>
HG: branch default
HG: changed sql.project/src/org/netbeans/modules/sql/project/ui/wizards/PanelProjectLocationVisual.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/builder/xsd/XSDGenerator.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/Bundle.properties
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/ChosenColumnPanel.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/InsertColumnPanel.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/JDBCWizardSelectionPanel.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/JDBCWizardTablePanel.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/JNDINamePanel.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/PolledColumnPanel.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/SimpleTargetChooserPanelGUI.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/UpdateColumnPanel.java

default branch: release61
Comment 12 nav064 2008-04-22 09:37:45 UTC
Issue 132273 - I18N - some words not from localized bundle files in wsdl from db  wizard
HG: user: Nav  <nav064@netbeans.org>
HG: branch default
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/Bundle.properties
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/JDBCWizardSelectionPanel.java
HG: changed sql.wizard/src/org/netbeans/modules/jdbcwizard/wizards/JDBCWizardTablePanel.java

default branch is main(here)
Comment 14 Ken Frank 2008-04-23 16:41:47 UTC
kaa,

this has been marked as resolved but not yet verified but 
we need to know so it can be in patch. is there a reason it has not
been able to be verified ?
Comment 15 kaa 2008-04-24 19:48:23 UTC
Product Version: NetBeans IDE Dev (Build 20080424124045)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; MS932; ja_JP (nb)
Comment 16 kaa 2008-04-24 19:49:02 UTC
Created attachment 60664 [details]
image
Comment 17 kaa 2008-04-24 19:53:29 UTC
The issue has been reproducible until now (1701, 1717 builds).
I vitrified with the latest pseudo jar file. Messages look ok.
Comment 18 kaa 2008-04-24 20:30:19 UTC
On Solaris 10 also looks ok.
Comment 19 pslechta 2008-04-28 16:18:21 UTC
Already fixed in release 6.1, right? This fix should not be part of patch 1...
Comment 20 Ken Frank 2008-04-28 16:27:48 UTC
I think perhaps this one and some others
in wsdl from db area that had this status
whiteboard for first patch,
had the code put to release61 branch
after the final fcs build, thus the fix
indeed might not be in release 61.

Nav, can you look at these recent issues
and see which fixes happened after the 
final nb fcs build for the issues you fixed
that was put into release61 branch ?


ken.frank@sun.com
Comment 21 pslechta 2008-04-29 11:07:17 UTC
This fix was partially integrated into NB 6.1 FCS build and partially into release61 repository.
Please avoid such changes in the future, it is confusing.
Now, I have to manually create new diff for patch 1...
Comment 22 pslechta 2008-04-29 14:21:50 UTC
All changes proposed by this fix are already in release61 repository and also in release61_fixes repository. So there is
nothing to port into release61_fixes repository... (everything is already there).

However, some of the changes were not included into FCS build (how is it possible???)

The module org.netbeans.modules.sql.wizard will be part of NB 6.1 patch 1 anyway (there are some changes from other
issues), so the changes from release61 repository will be propagated there too...

Marking as fixed for patch 1.
Comment 23 nav064 2008-04-30 12:13:08 UTC
http://hg.netbeans.org/release61/rev/ad9ccff0e55a

This changeset is already into release61. Some keys though not used, are added for future use, for 508 compliance, etc.
Please keep them as is.
Comment 24 Masaki Katakai 2008-05-02 05:08:30 UTC
I understand release61 branch is used for 6.1 ml release now and
we should release the same codes of English 6.1 FCS at 6.1 ml FCS.
So I think these extra changes that have not been integrated into 6.1 English FCS
should not be in release61 branch.

Sustaining team, what do you think?
Comment 25 Ken Frank 2008-05-02 06:11:48 UTC
Masaki,

this is so these msgs can be in the patch since patches are
translated and that was the process needed so they could go to
patch branch, but yes, agree that the code/bundles in actual
en fcs and ml fcs should be the same; I think sustaining
can clarify more about it.

ken.frank@sun.com
Comment 26 pslechta 2008-05-05 15:37:16 UTC
We are preparing English version of the NB 6.1 patch 1 right now. This patch should be translated into supported
languages later on. Sustaining coordinator for L10N is Rudolf Balada, so target any L10N questions to him, please...


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo