Bug 132203 - Cancel running task does not kill running process
Cancel running task does not kill running process
Status: RESOLVED WORKSFORME
Product: cnd
Classification: Unclassified
Component: -- Other --
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: _ gordonp
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 15:48 UTC by Alexander Pepin
Modified: 2008-07-30 15:02 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2008-04-07 15:48:13 UTC
This is a consequence of fixing issue #131739.

Steps to reproduce:
- create Quote sample project
- build the project
- set in project properties "Console Type" to "Output Window"
- run the project
- while the project is running try to cancel it via Quote_1(Build, Run) progress bar
Result: The Quote process is not killed when user cancels running. It's shown as working in "Task Manager" and even a
user can attach to it to debug from IDE. The last can mislead a user if he/she tries to debug Quote and runs it once
again. It also prevents the project from rebuilding. Moreover sometimes such processes continue working after closing
IDE and then they take up to 50% of processor time (probably because IDE is trying to kill them and I realized the
problem because of that).
Comment 1 Thomas Preisler 2008-04-07 16:53:50 UTC
I doubt it is a consequence of fixing issue #131739. I think it has been there all along.
Comment 2 _ gordonp 2008-04-23 00:42:48 UTC
Note: While the process persists after the Cancel, the project can be rebuilt and rerun (the
comment above states it cannot). As far as NetBeans is concerned, the cancel completed and the
project is ready for more actions.
Comment 3 Thomas Preisler 2008-07-24 17:49:23 UTC
Bug is in execution code in core.
Comment 4 Leonid Lenyashin 2008-07-28 12:54:19 UTC
If it is in core, then please reassign it to core. If it is note, please consider downgrading the bug, since as far as I
understand it was this way all the time - we did not regress.
Comment 5 Egor Ushakov 2008-07-30 11:14:15 UTC
I'm unable to reproduce it in trunk
Comment 6 Leonid Lenyashin 2008-07-30 12:24:27 UTC
If it is not reproducible, then make it P4 or close.
Comment 7 Alexander Pepin 2008-07-30 15:02:45 UTC
It's not reproducible any more. Verified in build 20080730


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo