Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 132141 - Setting default compiler set from validation panel is not preserved
Setting default compiler set from validation panel is not preserved
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: -- Other --
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Thomas Preisler
issues@cnd
61fixes1-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-05 19:26 UTC by Thomas Preisler
Modified: 2008-06-04 08:46 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Preisler 2008-04-05 19:26:41 UTC
If you change the default compiler set from the validation panel, the new value is not saved correctly and the setting
may be lost when you restart the IDE. There are other scenarios where the default compiler set is not set correctly. If
you set it from the global tool setup panel in Options|C/C++ everything is fine. Here is are some steps to reproduce:

1) Open global tool setup panel in Options|C/C++ and invalidate the make command and click OK
2) Open and try and build a project that uses the now invalid compiler set. The validation panel comes up.
3) Fix the error and also change default set to a different set. You may have to dup or add a new set. Click OK.
4) Exit and restart IDE.
5) Open global tool setup panel in Options|C/C++ and observe that default set hasn't changed.
Comment 1 Thomas Preisler 2008-04-05 19:57:00 UTC
I meant there are other scenarios where this causes problems. The cause is the same: default set is not preserved
correctly if set from validation panel.
Comment 2 Thomas Preisler 2008-04-05 20:16:24 UTC
Fixed in trunk:

changeset:   77373:4fcb2710bbab
user:        Thomas Preisler <thp@netbeans.org>
date:        Sat Apr 05 18:30:21 2008 -0700
summary:     132141 Setting default compiler set from validation panel is not preserved

Comment 3 Thomas Preisler 2008-04-05 20:39:45 UTC
changeset 4fcb2710bbab in main
details: http://hg.netbeans.org/main?cmd=changeset;node=4fcb2710bbab
description:
	132141 Setting default compiler set from validation panel is not preserved
Comment 4 Thomas Preisler 2008-04-16 16:37:57 UTC
6.1 patch candidate.
Comment 5 alexandrov 2008-04-18 18:40:49 UTC
verified in trunk 200804180004
Comment 6 rbalada 2008-04-29 15:17:21 UTC
I've transplanted the changeset http://hg.netbeans.org/main?cmd=changeset;node=4fcb2710bbab
into release61_fixes repository as http://hg.netbeans.org/release61_fixes/rev/1be733d2d7d2

changeset:   77506:1be733d2d7d2
user:        Thomas Preisler <thp@netbeans.org>
date:        Sat Apr 05 18:30:21 2008 -0700
summary:     132141 Setting default compiler set from validation panel is not preserved


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo