Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 132121 - Detect EclipseLink when default provider in GF V3
Detect EclipseLink when default provider in GF V3
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: Persistence
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Dongmei Cao
issues@javaee
61fixes2-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-05 00:06 UTC by _ ludo
Modified: 2008-07-10 15:07 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ ludo 2008-04-05 00:06:58 UTC
I see the eclipselink JPA provider has been added last week to Nb 6.1 (http://hg.netbeans.org/main/rev/0e761d4c329c) but
this is incomplete to be functional for GF V3 (or others).
It seems that there is still missing code to make it available like kodo or openjpa are.
See code for example under:
org.netbeans.modules.web.project.WebPersistenceProviderSupplier
it lists:
        addPersistenceProvider(ProviderUtil.HIBERNATE_PROVIDER, "hibernatePersistenceProviderIsDefault", platform,
result); // NOI18N
        addPersistenceProvider(ProviderUtil.TOPLINK_PROVIDER, "toplinkPersistenceProviderIsDefault", platform,
result);// NOI18N
        addPersistenceProvider(ProviderUtil.KODO_PROVIDER, "kodoPersistenceProviderIsDefault", platform, result); // NOI18N
        addPersistenceProvider(ProviderUtil.OPENJPA_PROVIDER, "openJpaPersistenceProviderIsDefault", platform, result);
// NOI18N



but nothing for EclipseLink

Also, trying to add a new persistence library, even if I add the eclipselink libraries, I still get
a red error with "EntityManager is not present on library" message.

So so far, I am not able to register eclipselink or register it...
Comment 1 _ ludo 2008-04-05 00:20:32 UTC
P3: If I add the JPA apis in the library definition I can create the lib, so it seems that EclipseLink does not include
the api jar.
That's fine.
Still P3 for the webproject (and possibly other project types) lack of exposure with EclipseLink.
Comment 2 Andrei Badea 2008-04-07 13:08:37 UTC
EclipseLink includes the API jar in a separate library which you of course need to add to the library. As for detecting
the EclipseLink as the default provider in GF V3, that is an enhancement.
Comment 3 _ ludo 2008-06-02 23:33:28 UTC
trunk fix is http://hg.netbeans.org/main/rev/8d9f40c0a920
Comment 4 _ pcw 2008-06-02 23:58:04 UTC
Nominating for NB 6.1 Patch 2.  It is needed by the GlassFish V3 JavaEE Integration plugin for correct display of
EclipseLink JPA support.
Comment 5 Dongmei Cao 2008-06-03 06:52:52 UTC
So, ludo, this is fixed? If yes, please mark it as FIXED.
Comment 6 pgebauer 2008-06-03 09:57:13 UTC
The patches are intended for defect bugfixing only but not for an enhancement implementation. If this issue is a real
enhancement, please remove it from the patch. If it is a defect, please change the issue type. Thanks.
Comment 7 pslechta 2008-06-03 14:15:45 UTC
Please clarify if this issue is fixed or not (it has still status NEW).
The diff shows just one line added, so I suppose it is a fix (not an enhancement).
If it should go into patch 2, then we need verification from QA.
Comment 8 _ ludo 2008-06-03 22:53:26 UTC
fix in trunk
Comment 9 _ ludo 2008-06-03 22:54:30 UTC
assigning tot dongmeic for the branching work
Comment 10 _ ludo 2008-06-03 22:55:16 UTC
f in trunk
Comment 11 pslechta 2008-06-04 09:32:23 UTC
The fix needs to be verified by QA. QA, can you verify it till 10-Jun-2008?
Then it will be ported by sustaining to patch 2...
Comment 12 pgebauer 2008-06-10 13:44:16 UTC
This issue has been nominated for NB IDE 6.1 patch2 although it hasn't been verified by QE yet. If it isn't verified by
12-Jun-08, it's nomination will be removed.
Comment 13 Petr Blaha 2008-06-10 14:17:12 UTC
Verified in the latest trunk build.
Comment 14 _ ludo 2008-06-10 15:52:47 UTC
the only way to verify it is to use the GF V3 plugin from the contrib source code.
Create a web app with this server target, and create JPAs from DB. You should see the EclipseLink provider as the
default for it.
I've verified the behaviour.
The change has no effect for all the other server plugins
Comment 15 pslechta 2008-06-10 17:22:37 UTC
The fix has been ported into the release61_fixes repository.

http://hg.netbeans.org/release61_fixes/rev/c2c74bec8b31


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo