Bug 132055 - I18N - Module properties dlg has resize problem
I18N - Module properties dlg has resize problem
Status: RESOLVED WONTFIX
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All All
: P2 (vote)
: TBD
Assigned To: Jesse Glick
issues@apisupport
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-04 13:50 UTC by kaa
Modified: 2008-04-04 18:17 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
image (110.53 KB, image/jpeg)
2008-04-04 13:51 UTC, kaa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaa 2008-04-04 13:50:41 UTC
Product Version: NetBeans IDE Dev (Build 200803301102)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; MS932; ja_JP
font size 16

Steps:
1. Create NetBeans Module using wizard defaults
2. Open project properties dialog
3. Select API Versioning

The dialog does not resize to show all of its text.

Assumption is that user does not need to manually resize most windows or dialogs to see all of the UI objects and
information in them. I'm running in pseudo localized locale in which each message/label is sometimes longer than in
English. To account for that in some locales, translations from English (and some other euro languages) could be shown
with longer strings.

Also I'm running at font size 16, which is viewed as a valid font size that might be used. Resizing issues are not just
related to i18n; they might show to user in English locale if they run at larger font size.

Often, these issues happen because the length of some label or message or size of entire window is hardcoded vs using
layout managers or other techniques or api to have the windows or the objects in them, dynamically resize. Sometimes,
embedding components in a scroll pane will solve the problem.
Comment 1 kaa 2008-04-04 13:51:01 UTC
Created attachment 59681 [details]
image
Comment 2 kaa 2008-04-04 13:53:48 UTC
Resize using horiz scrollbar doesn't help
Comment 3 Jesse Glick 2008-04-04 18:17:34 UTC
Can't reproduce what you describe in the last comment. With e.g. --fontsize 18 (JDK 6, Ubuntu 7.10, Ocean) this panel is
indeed cramped when initially displayed, but looks fine if you make the dialog a bit bigger. AFAIK the project has no
control over how big the dialog box is initially opened, there is just a standard fixed size. Anyway this is no
different from any other project type, such as Java SE projects (which are used far more than NBM projects); if your
font size is too big, the dialog will probably be cramped until you make the dialog bigger.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo