Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 132046 - Navigator - Display name isn't changed
Navigator - Display name isn't changed
Status: VERIFIED FIXED
Product: javame
Classification: Unclassified
Component: Visual Designer
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Karol Harezlak
issues@mobility
61fixes1-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-04 13:09 UTC by Lukas Hasik
Modified: 2008-06-04 08:39 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (140.87 KB, image/png)
2008-04-04 14:33 UTC, Lukas Hasik
Details
Diff file (2.46 KB, text/plain)
2008-04-23 15:37 UTC, Karol Harezlak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2008-04-04 13:09:35 UTC
Product Version: NetBeans IDE Dev (Build 200803311426)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19
System: Windows Vista version 6.0 running on x86; Cp1252; en_US (nb)
Userdir: C:\data\netbeans\userdir\nb61-0402-coverage

-rename a component(alert) with Rename action on component in Navigator
-node name is still the same BUT in flow design/properties it is the new one
Comment 1 Karol Harezlak 2008-04-04 13:32:43 UTC
Is it happens every time? I was trying to reproduce it but no luck. Could you send me your project?
Comment 2 Lukas Hasik 2008-04-04 14:33:37 UTC
Created attachment 59688 [details]
screenshot
Comment 3 Petr Dvorak 2008-04-09 15:43:57 UTC
Probably duplicate of http://www.netbeans.org/issues/show_bug.cgi?id=131066 - the same problem holds for delete action.
Comment 4 Lukas Hasik 2008-04-23 13:42:59 UTC
really annoying bug that leaves you confused...
Comment 5 Karol Harezlak 2008-04-23 15:37:06 UTC
Created attachment 60609 [details]
Diff file
Comment 6 Karol Harezlak 2008-04-23 15:37:56 UTC
Fixed in the main trunk.

vmd.inspector/src/org/netbeans/modules/vmd/inspector/InspectorFolderNode.java
vmd.inspector/src/org/netbeans/modules/vmd/inspector/InspectorFolderWrapper.java

changeset:   78896:174f9a7203b2
user:        Karol Harezlak <kharezlak@netbeans.org>
date:        Wed Apr 23 15:56:16 2008 +0200
summary:     Issue 132046 Navigator - Display name isn't changed

Diff file attached to the previous entry.
Comment 7 Lukas Hasik 2008-04-24 15:37:19 UTC
verified in trunk

Product Version: NetBeans IDE Dev (Build 200804240003)
Java: 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Userdir: F:\netbeans\userdir\nbDev0424
Comment 8 jinb 2008-04-29 18:31:40 UTC
fix backported into release61_fixes branch
Comment 9 jinb 2008-04-30 15:23:27 UTC
release61_fixes changeset: 77514:454045473f05
Comment 10 Jaromir Uhrik 2008-05-19 16:36:02 UTC
Verified in 6.1fcs+patch1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo