Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 131954 - Unexpected new line after comment
Unexpected new line after comment
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Editor
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
61fixes1-fixed
:
: 132117 133509 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-03 16:14 UTC by deniss
Modified: 2008-06-04 08:35 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description deniss 2008-04-03 16:14:22 UTC
Product Version: NetBeans IDE Dev (Build 200804030004)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: Linux version 2.6.22-14-generic running on i386; UTF-8; cs_CZ (nb)

int a; // Uff
int b;

After formatting:
int a; // Uff

int b;

Expected:
int a; // Uff
int b;

its really annoying :)
Comment 1 Jiri Prox 2008-04-07 07:11:53 UTC
*** Issue 132117 has been marked as a duplicate of this issue. ***
Comment 2 Dusan Balek 2008-04-14 12:49:57 UTC
Fixed.

changeset 3aa74a5c07ed in main
details: http://hg.netbeans.org/main?cmd=changeset;node=3aa74a5c07ed
Comment 3 Jiri Prox 2008-04-22 07:48:52 UTC
*** Issue 133509 has been marked as a duplicate of this issue. ***
Comment 4 Jiri Prox 2008-04-23 09:44:51 UTC
I can still reproduce it in 

Product Version: NetBeans IDE Dev (Build 20080423054047)
Java: 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11
System: Linux version 2.6.22-14-generic running on i386; UTF-8; en_US (nb)
default formatting settings

code:

public class TestClass {

    int a; //comment
    int b;
}
Comment 5 Dusan Balek 2008-04-29 16:11:11 UTC
Fixed.

changeset 6c04689d3cb0 in main
details: http://hg.netbeans.org/main?cmd=changeset;node=6c04689d3cb0
Comment 6 Quality Engineering 2008-04-30 04:34:28 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #166 build
Changeset: http://hg.netbeans.org/main/rev/6c04689d3cb0
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #131954: Unexpected new line after comment - fixed.
Comment 7 Jiri Prox 2008-04-30 10:45:02 UTC
verified, thanks

Product Version: NetBeans IDE Dev (Build 20080429222325)
Java: 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11
System: Linux version 2.6.22-14-generic running on i386; UTF-8; en_US (nb)
Comment 8 pgebauer 2008-04-30 20:49:13 UTC
The fix has been ported into the release61_fixes branch:

http://hg.netbeans.org/release61_fixes/rev/5aa2aa52fcb6
http://hg.netbeans.org/release61_fixes/rev/0826ea483701


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo