Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 131928 - [Change Parameters] Parameter is not removed from method calls
[Change Parameters] Parameter is not removed from method calls
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Refactoring
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jan Pokorsky
issues@java
61fixes2-fixed
: REGRESSION
: 133177 134540 (view as bug list)
Depends on:
Blocks: 129376
  Show dependency treegraph
 
Reported: 2008-04-03 13:34 UTC by Jiri Prox
Modified: 2008-07-10 15:03 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Prox 2008-04-03 13:34:08 UTC
Product Version: NetBeans IDE Dev (Build 200803311211)
Java: 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11
System: Linux version 2.6.22-14-generic running on i386; UTF-8; en_US (nb)

When using Change method parameter refactoring to remove one of the methods parameter, the methods call are not updated. 

Steps to reproduce:
1) have class  Main with method test(int, int)
2) have class Class2 where method test(int int) is called
3) put caret at methods declaration and call Change parameters
4) remove last parameter
-> usage in Class2 is not updated

adding parameter works fine
Comment 1 Jan Pokorsky 2008-04-03 18:28:31 UTC
regression caused by http://hg.netbeans.org/main/rev/94a978249fa2
Comment 2 Jan Pokorsky 2008-04-04 17:21:56 UTC
fixed as http://hg.netbeans.org/main/rev/912473b9714a
Comment 3 Jiri Prox 2008-04-21 09:30:52 UTC
*** Issue 133177 has been marked as a duplicate of this issue. ***
Comment 4 Jiri Prox 2008-05-06 09:45:23 UTC
*** Issue 134540 has been marked as a duplicate of this issue. ***
Comment 5 Jiri Prox 2008-05-06 09:45:30 UTC
nominating for patch2
Comment 6 Jiri Prox 2008-06-03 08:31:24 UTC
verified

Product Version: NetBeans IDE Dev (Build 20080603031252)
Java: 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11
System: Linux version 2.6.22-14-generic running on i386; UTF-8; en_US (nb)
Comment 7 pgebauer 2008-06-03 14:24:50 UTC
The fix has been ported into the release61_fixes branch:

http://hg.netbeans.org/release61_fixes/rev/d6c0149dddba


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo