Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 131901 - [serial] serializable class SimplifiedJSPServlet has no definition of serialVersionUID
[serial] serializable class SimplifiedJSPServlet has no definition of serialV...
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: JSP
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Tomasz Slota
issues@javaee
61fixes1-fixed
: SIMPLEFIX
: 131530 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-03 09:33 UTC by davideconsonni
Modified: 2008-06-04 08:47 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
warning on first line (16.18 KB, image/png)
2008-04-03 09:34 UTC, davideconsonni
Details

Note You need to log in before you can comment on or make changes to this bug.
Description davideconsonni 2008-04-03 09:33:26 UTC
im getting 
[serial] serializable class SimplifiedJSPServlet has no definition of serialVersionUID
warning message if i write text on first line of jsps, with empty first line there no warning.

an example on screenshoot attachment.

editor:
Product Version: NetBeans IDE Dev (Build 080403)
Java: 1.6.0_02; Java HotSpot(TM) Client VM 1.6.0_02-b05
System: Linux version 2.6.24.2-smp running on i386; ISO-8859-1; en_US (nb)
Comment 1 davideconsonni 2008-04-03 09:34:02 UTC
Created attachment 59597 [details]
warning on first line
Comment 2 Tomasz Slota 2008-04-07 12:33:12 UTC
*** Issue 131530 has been marked as a duplicate of this issue. ***
Comment 3 Tomasz Slota 2008-04-07 12:40:21 UTC
reproducible when the Java Code->Hints->Standard Javac warnings->Serialization option is checked (off by default). Quite annoying, upgrading to P2. 
Should be trivial to fix
Comment 4 Jiri Prox 2008-04-11 01:11:54 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 5 Tomasz Slota 2008-04-21 09:18:14 UTC
Fixed.

http://hg.netbeans.org/main/rev/bf02e0188807
Comment 6 Quality Engineering 2008-04-22 11:36:01 UTC
Issue '131901' Integrated in NB_Trunk_Production #150 : http://hg.netbeans.org/main/rev/bf02e0188807,
 with comment: #131901: serializable class SimplifiedJSPServlet has no definition of serialVersionUID
Comment 7 Quality Engineering 2008-04-23 03:58:25 UTC
Issue '131901' Integrated in NB_Trunk_Production #152 : http://hg.netbeans.org/main/rev/bf02e0188807,
 with comment: #131901: serializable class SimplifiedJSPServlet has no definition of serialVersionUID
Comment 8 Jindrich Sedek 2008-04-23 07:41:14 UTC
verified in trunk
Comment 9 pslechta 2008-04-28 15:56:50 UTC
The fix has been ported into the release61_fixes branch.

http://hg.netbeans.org/release61_fixes/rev/3b36aa06cb52


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo