Bug 131730 - NPE of Find in memory results
NPE of Find in memory results
Status: VERIFIED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
PC All
: P2 (vote)
: 6.x
Assigned To: Jiri Sedlacek
issues@profiler
: VISUALVM
: 125860 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 15:40 UTC by Maksim Khramov
Modified: 2008-08-19 15:24 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maksim Khramov 2008-04-01 15:40:10 UTC
Product Version: NetBeans IDE Dev (Build 200804010004)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19

Steps to reproduce:
Create test application and perform memory profiling for it.
Take memory snapshot and invoke Find in Results command.
Type any class name (for example String) and click OK.
The NPE is thrown:
java.lang.NullPointerException
	at org.netbeans.modules.profiler.MemorySnapshotPanel.performFind(MemorySnapshotPanel.java:342)
	at org.netbeans.modules.profiler.SnapshotResultsWindow$1.actionPerformed(SnapshotResultsWindow.java:377)
	at org.openide.util.actions.CallbackSystemAction.actionPerformed(CallbackSystemAction.java:204)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
	at java.awt.Component.processMouseEvent(Component.java:6041)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3265)
	at java.awt.Component.processEvent(Component.java:5806)
	at java.awt.Container.processEvent(Container.java:2058)
	at java.awt.Component.dispatchEventImpl(Component.java:4413)
	at java.awt.Container.dispatchEventImpl(Container.java:2116)
	at java.awt.Component.dispatchEvent(Component.java:4243)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4322)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3986)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3916)
	at java.awt.Container.dispatchEventImpl(Container.java:2102)
	at java.awt.Window.dispatchEventImpl(Window.java:2440)
	at java.awt.Component.dispatchEvent(Component.java:4243)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:104)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)
Comment 1 Jiri Sedlacek 2008-06-16 13:32:25 UTC
Reproduced. This only happens when Record stack trace for allocations option was disabled for profiling. As a workaround
filtering & sorting by classname can be used.
Comment 2 Jiri Sedlacek 2008-06-18 11:39:58 UTC
Fixed for 6.5 M1.

changeset:   84925:a2768f114c21
date:        Wed Jun 18 12:34:57 2008 +0200
summary:     Bugfix #131730 Search string not set for null panel
Comment 3 Quality Engineering 2008-06-18 15:58:43 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #267 build
Changeset: http://hg.netbeans.org/main/rev/a2768f114c21
User: Jiri Sedlacek <jis@netbeans.org>
Log: Bugfix #131730 Search string not set for null panel
Comment 4 Rashid Urusov 2008-06-19 18:08:01 UTC
verified in build 20080619009
Comment 5 Quality Engineering 2008-06-27 16:00:42 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #285 build
Changeset: http://hg.netbeans.org/main/rev/a5dcc82812e3
User: Jiri Sedlacek <jis@netbeans.org>
Log: Bugfix #131730 Do not set JComboBox border for custom JComponent on GTK
Comment 6 Tomas Hurka 2008-06-27 16:07:14 UTC
Note that above info is incorrect. There is a typo in above commit message. #131730 should be #135812.
Comment 7 Tomas Hurka 2008-08-19 15:24:20 UTC
*** Issue 125860 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo