Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 131639 - Problem with Included Schemas in Mapper
Problem with Included Schemas in Mapper
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: BPEL Mapper
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Nikita Krjukov
issues@soa
61fixes1-fixed
:
Depends on: 132301
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 16:02 UTC by davelane
Modified: 2008-06-04 08:46 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Sample (10.05 KB, application/octet-stream)
2008-03-31 16:04 UTC, davelane
Details
compilation output (37.58 KB, text/plain)
2008-04-29 17:36 UTC, pslechta
Details

Note You need to log in before you can comment on or make changes to this bug.
Description davelane 2008-03-31 16:03:08 UTC
We have a wsdl with an included schema. When I try to map elements with types from the included schema we see the following:
1. In one case the node has name <?UNKNOEN NODE TYPE?>
2. In the second case the node cannot be expanded

See example project.
Comment 1 davelane 2008-03-31 16:04:11 UTC
Created attachment 59418 [details]
Sample
Comment 2 barz26 2008-04-04 09:45:38 UTC
The problem was initially reported against 6.0 but is still reproducable with 6.1beta. 
It seems that if an element from an included schema is referenced it can't be accessed in the bpel mapper.

EG:
 <xsd:include schemaLocation="xyz.xsd"/> <- defines Element AElement
...
<xsd:element name="AResponse">
                <xsd:complexType>
                    <xsd:sequence>
                        <xsd:element ref="AElement"></xsd:element>
                    </xsd:sequence>
                </xsd:complexType>
            </xsd:element>
In the BPEL Mapper you can't drill down to the AElement Type.
This makes included schemas not really usable in the BPEL tooling -> Thus raising to P1.

Comment 3 Alexey Yarmolenko 2008-04-08 11:21:16 UTC
This problem goes to Schema model, so I created an issue against it: iz132301.

As a workaround, one can copy targetNamespace declaration from schema, inlined in wsdl
(targetNamespace="http://afb.de/Schufa") to included xsd file(schufa.xsd)
Comment 4 Petr Blaha 2008-04-10 17:18:45 UTC
The bug will be fixed via patch1 and since the workaround exists, the P2 priority is appropriate. Please, work on the
fix in the trunk. Thanks
Comment 5 Nikita Krjukov 2008-04-23 12:47:42 UTC
Fixed in trunk
Comment 6 Quality Engineering 2008-04-23 15:55:21 UTC
Issue '131639' Integrated in NB_Trunk_Production #153 : http://hg.netbeans.org/main/rev/b6415dca5f39,
 with comment: Fix the issue #131639 - Problem with Included Schemas in Mapper
Comment 7 Sergey Lunegov 2008-04-23 16:33:09 UTC
marked as fixed.
Comment 8 pgebauer 2008-04-25 11:26:20 UTC
The issue hasn't be verified till 61patch1 nomination cut-off date.
Marked as release61_fixes_candidate2.
Comment 9 Victoria Zhukovskaya 2008-04-25 13:15:22 UTC
Build 20080425082446
trunk 1729

verified sample
There are no nodes with <?UNKNOEN NODE TYPE?> name
There are all nodes can be expanded

Comment 10 Sergey Lunegov 2008-04-25 13:49:20 UTC
verified by Vika. returned back to patch1 candidates list.
Comment 11 pslechta 2008-04-29 15:17:29 UTC
The fix has been ported into the release61_fixes branch.

http://hg.netbeans.org/release61_fixes/rev/32a6602d3f8e
Comment 12 pslechta 2008-04-29 17:09:35 UTC
After applying the fix, the module bpel.mapper does not compile anymore. See attached log.
It seems that the fix is incomplete. Please evaluate and provide complete fix in 5 days (till May 5th) otherwise this
fix cannot be part of patch 1.
Comment 13 pslechta 2008-04-29 17:36:51 UTC
Created attachment 60814 [details]
compilation output
Comment 14 pslechta 2008-04-30 14:00:44 UTC
The change http://hg.netbeans.org/release61_fixes/rev/32a6602d3f8e was rolled back in release61_fixes branch because it
broke the build.

Anyway, the changes in the fix are huge (19 files affected), so it is controversial if such huge changes should be part
of patch 1 (is it really bug fix or bug fix + some refactoring?)...
Comment 15 Nikita Krjukov 2008-04-30 15:49:45 UTC
The fix changed 19 files because the changes are quite complex. But it fixes the real problem.
And I'm sure that it is safe enough to be included to the patch.

I think it is inevitable that merging big amount of changes can come to build problems.
Most likely it can be a result of skipping some changesets while merging.
But regarding my code, I can try merging it manually and make it compilable.

I have seen the console log., It looks strange for me, but I think it isn't very difficult to fix.

Comment 16 Nikita Krjukov 2008-05-04 14:42:56 UTC
I have sent the hg bundle with changeset by email. 
So I hope the fix will be in the patch1. 
Comment 17 pslechta 2008-05-05 14:12:09 UTC
The fix has been ported into the release61_fixes branch. (Thanks for the bundle, supernikita!)

http://hg.netbeans.org/release61_fixes/rev/b5b46d426b49


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo