Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 131619 - AssertionError at org.netbeans.api.java.source.GeneratorUtilities.insertClassMember
AssertionError at org.netbeans.api.java.source.GeneratorUtilities.insertClass...
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Refactoring
6.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@java
issues@java
http://statistics.netbeans.org/except...
61fixes2-fixed EXCEPTIONS_REPORT
:
: 134366 135269 135766 136203 136222 136645 138719 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 13:38 UTC by Kenneth Ganfield
Modified: 2008-07-10 15:10 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.62 KB, text/plain)
2008-03-31 13:38 UTC, Kenneth Ganfield
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Ganfield 2008-03-31 13:38:02 UTC
Build: NetBeans IDE Dev (Build 20080328082319)
VM: Java HotSpot(TM) Client VM, 1.5.0_13-121, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_13-b05-241
OS: Mac OS X, 10.4.11, i386

User Comments: 
using the refactor > Encapsulate fields dialog
Comment 1 Kenneth Ganfield 2008-03-31 13:38:06 UTC
Created attachment 59401 [details]
stacktrace
Comment 2 Jan Lahoda 2008-03-31 13:42:46 UTC
Seems that either clazz or member parameter of GU.iCM was null.
Comment 3 Jan Pokorsky 2008-04-02 19:04:54 UTC
fixed as http://hg.netbeans.org/main/rev/744a8926ce86
Comment 4 Jan Pokorsky 2008-05-15 16:02:49 UTC
*** Issue 134366 has been marked as a duplicate of this issue. ***
Comment 5 Jan Pokorsky 2008-05-19 13:24:32 UTC
*** Issue 135269 has been marked as a duplicate of this issue. ***
Comment 6 Jiri Prox 2008-06-02 08:43:27 UTC
*** Issue 136222 has been marked as a duplicate of this issue. ***
Comment 7 Jiri Prox 2008-06-02 08:53:06 UTC
*** Issue 136203 has been marked as a duplicate of this issue. ***
Comment 8 Jiri Prox 2008-06-03 09:54:41 UTC
verified
Comment 9 pgebauer 2008-06-03 14:38:58 UTC
The fix has been ported into the release61_fixes branch:

http://hg.netbeans.org/release61_fixes/rev/78519f45e4df
Comment 10 Jiri Prox 2008-06-09 09:43:48 UTC
*** Issue 136645 has been marked as a duplicate of this issue. ***
Comment 11 Jan Pokorsky 2008-07-01 17:46:59 UTC
*** Issue 138719 has been marked as a duplicate of this issue. ***
Comment 12 Jan Pokorsky 2008-07-10 14:44:11 UTC
*** Issue 135766 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo