Bug 131531 - Git VCS support
Git VCS support
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Git
6.x
All Linux
: P1 with 191 votes (vote)
: 7.0
Assigned To: Ondrej Vrabec
issues@versioncontrol
http://groups.google.com/group/nbgit/
:
: 133042 135364 160616 166522 172336 184909 192267 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-29 21:03 UTC by urlwolf
Modified: 2010-11-29 14:09 UTC (History)
30 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description urlwolf 2008-03-29 21:03:47 UTC
please add git support
Comment 1 richo 2008-04-03 22:58:18 UTC
+1, this is increasingly necessary for Ruby on Rails development
Comment 2 jamespb 2008-04-04 00:19:01 UTC
http://weblog.rubyonrails.com/2008/4/2/rails-is-moving-from-svn-to-git

+1 from me as well.  Git has become a requirement for a Ruby on Rails development environment.
Comment 3 Martin Krauskopf 2008-04-04 10:11:46 UTC
Can anybody from versioncontrol team give us some information whether there are some plans for the Git support or not.
Even "Haven't been considered at all yet" would be useful to know. Thanks.
Comment 4 bhauff 2008-04-04 14:01:30 UTC
My request for 7.0 or as soon as possible would be Git support.  Git is now the official repository for Ruby on Rails. 
http://weblog.rubyonrails.com/2008/4/2/rails-is-moving-from-svn-to-git  So it would be great to not get behind so to speak.
Comment 5 mvyver 2008-04-06 02:20:51 UTC
FYI,

http://gitorious.org/projects/nbgit

I've not used it, but it is there and is probably as good a starting point as any, or for people who are able to help out.

HTH?
Comment 6 pramodkc 2008-04-06 21:02:45 UTC
1 more vote for git. 
Comment 7 Tomas Stupka 2008-04-07 19:18:34 UTC
> Can anybody from versioncontrol team give us some information whether there are some plans for the Git support or not.
> Even "Haven't been considered at all yet" would be useful to know. Thanks.
well, it has been considered. More info available at http://versioncontrol.netbeans.org/#community_support

> http://gitorious.org/projects/nbgit
this is good news. As mentioned under the link above - we like to help as much as possible ...

Comment 8 blackdog 2008-04-10 22:45:14 UTC
+1
i don't use ruby but git is my preferred tool, right now i use git-gui for my java dev.
Comment 9 myabc 2008-04-12 12:41:50 UTC
Hello,

I set up the project that was mentioned in this thread: -
http://github.com/myabc/nbgit/tree/master
http://gitorious.org/projects/nbgit

I am basing the plugin around NetBeans's Mercurial support, and in fact, have ported code from that module as a starting basis.
Any thoughts on what you would like to see, as well as offers of support, are very gratefully received.
Comment 10 blackdog 2008-04-12 15:15:39 UTC
I think it's very useful (important even) to have the staging area represented correctly,
so that you  can see all your changes and then select which changes should be committed together or not.
I prefer this way of working with git as i tend to do a lot of stuff at once and then go back and sort out how I want
to group and commit later on. I mention this as the semantics are probably not in the mercurial plugin, but if you have
a look at git-gui they are.

Also, the amend commit functionality is very useful.

Thanks for starting this! Awesome. Netbeans is becoming my environment of choice and this functionality is the deal
closer for me.
Comment 11 Peter Pis 2008-04-17 09:57:51 UTC
*** Issue 133042 has been marked as a duplicate of this issue. ***
Comment 12 Tomas Stupka 2008-05-19 19:12:07 UTC
*** Issue 135364 has been marked as a duplicate of this issue. ***
Comment 13 sbwcgroup 2008-06-28 23:33:42 UTC
+1
Comment 14 ascarter 2008-07-07 19:52:22 UTC
+1 Adding my vote for Git
Comment 15 bhauff 2008-07-15 15:33:04 UTC
Looks like the project nbgit mentioned and linked below has stalled out.

http://groups.google.com/group/nbgit/browse_thread/thread/f80388bfe6688b2b

Is anyone else looking at adding git support to Netbeans?
Comment 16 zven 2008-07-26 11:35:49 UTC
+1 much needed. Since we have Rails support it's absolutely required, also needed for the sake of beautiful github.
Comment 17 nazggul 2008-09-02 12:24:21 UTC
Hi,

I started patching nbgit to make it work with git 1.6.0. If somebody is interested in it, you a welcome to contact me.

P.S. I can publish my local nbgit git repository.
P.P.S. Unfortunately, I'm quite busy and patching of this module is quite slow :(
Comment 18 gthiruva 2008-09-02 17:58:22 UTC
nazggul - Are your changes aimed at NB 6.5?
Comment 19 nazggul 2008-09-02 18:08:57 UTC
gthiruva: not now. NB 6.5beta is quite buggy for me. I'll try to make this module work with NB 6.5 when it will be released.
Comment 20 nazggul 2008-09-05 18:19:58 UTC
Oh, I've made some typo because http://github.com/myabc/nbgit/tree/master is not forgotten and last commit was made 6
hours ago.
Anyway I send my small patches to developers of this version of nbgit.
Comment 21 Martin Krauskopf 2008-09-21 08:24:46 UTC
BTW, already 6th most voted feature in the whole NetBeans:

  http://qa.netbeans.org/bugzilla/dashboards/top-voted.html
Comment 22 lmassand 2008-10-21 20:10:43 UTC
I am a huge Netbeans fan. In absence of GIT support I'll have to migrate to Eclipse which supports GIT
Comment 23 jamamooga 2008-10-22 22:57:54 UTC
I found a nbm that worked for me with Netbeans 6.1 here:
http://code.google.com/p/nbgit/downloads/list
Comment 24 callagga 2009-01-30 10:29:20 UTC
+1 for me as key feature required 
Comment 25 qbass 2009-01-30 23:16:41 UTC
+1!
Comment 26 auxbuss 2009-03-09 17:13:28 UTC
+1
Comment 27 Ondrej Vrabec 2009-03-26 08:58:49 UTC
*** Issue 160616 has been marked as a duplicate of this issue. ***
Comment 28 seengee 2009-04-14 14:18:51 UTC
+1 for Git support. its the standard for most new Open Source Projects.
Comment 29 sujoy 2009-04-14 14:28:27 UTC
+1 git really needs to be there.
Comment 30 k776 2009-06-03 06:13:41 UTC
+1  This is a big need for Ruby on Rails development, especially with Ruby on Rails and most open source ruby projects
moving over to Github!!
Comment 31 robo47 2009-06-03 09:19:02 UTC
+1 would really like to see it in 6.7
Comment 32 Erno Mononen 2009-06-08 13:47:06 UTC
*** Issue 166522 has been marked as a duplicate of this issue. ***
Comment 33 pcornelissen 2009-06-29 15:54:16 UTC
pretty funny that kenai etc supports git, but netbeans doesn't.
Any news on git for netbeans?
nbgit seems to be dead
Comment 34 blissfull 2009-06-30 01:03:13 UTC
nbgit is not dead, it's moved to github: http://github.com/myabc/nbgit/tree/master
Comment 35 pcornelissen 2009-06-30 07:04:32 UTC
Thanks! Lincoln also wrote me an email that git is working on nb6.7.

Maybe you should upload a downloadable release on the site (maybe even in a nb plugin repository?), because I don't
think that many people will try to compile it on their own.
Comment 36 bhauff 2009-08-02 20:05:08 UTC
nbgit is completely stalled.  At least one of the developers said that its current state fulfilled his need.  I think
this needs to be taken up by the versioncontrol team, the 3rd party plugin route isn't really working too well.
Comment 37 pcornelissen 2009-08-02 22:12:58 UTC
that would be great
Comment 39 verant 2009-09-07 06:36:47 UTC
+1 very need
Comment 40 Tomas Stupka 2009-09-16 06:28:12 UTC
*** Issue 172336 has been marked as a duplicate of this issue. ***
Comment 41 theyaa 2009-09-16 22:24:41 UTC
+1 from me also on getting Git integrated into netbeans. The nbgit plugin is useless, I can not use it to connect to a 
remote repository, plus, there is only one developer working on it when her gets the time.

Git has become the real repository for RoR project.

Versioncontrol team, please respond to us?
Comment 42 Petr Jiricka 2009-09-17 09:00:03 UTC
Right now this is the 3rd most voted for enhancement in NetBeans. Also, here is some interesting data:
http://www.google.com/trends?q=git%2Cmercurial%2Csubversion&ctab=0&geo=all&date=all&sort=0
Comment 43 gthiruva 2009-09-17 19:22:04 UTC
Cool chart. Though, apparently 'git' must be word in Turkish so that kind of skews the results. Taking Turkey out of the data yields a new, but still convincing 
chart: http://www.google.com/trends?q=git%2Cmercurial%2Csubversion&ctab=0&geo=us&date=all&sort=0
Comment 44 Jaroslav Tulach 2009-09-18 07:36:08 UTC
It is fun to watch your arguments. Consider removing occurrences in "Chinese civil rights activist sentenced to 3 1/2 
years for subversion" and co.
Comment 45 kurti 2009-09-18 08:08:30 UTC
jtulach, you are right, the charts are bogus, as both git and mercurial came into existence in spring 2005. This chart
looks more like the real world notion of both. I became aware of GIT shortly before Linus made his speech at Google in
May 3rd 2007:

http://www.google.com/trends?q=git+linux%2Cmercurial+hg%2Csubversion+svn&ctab=0&geo=all&geor=all&date=all&sort=0

Still the point is, that GIT is used by quite some FOSS projects:

http://en.wikipedia.org/wiki/Git_%28software%29#Projects_using_Git
http://en.wikipedia.org/wiki/Mercurial_%28software%29#Projects_using_Mercurial

so some support within NetBeans would be nice to have.
Comment 46 Erno Mononen 2009-09-18 08:10:21 UTC
Notwithstanding the skewed graph, there is little doubt that git is rapidly gaining popularity. And it is not just 
because of Ruby users - that is one of the reasons EY, a Rails shop, no longer hosts GitHub: http://www.engineyard.com/
blog/2009/engine-yard-and-github-transition/ (well, at least that is the reason they give to public).
Comment 47 bebraw 2009-09-18 08:46:55 UTC
This might be a long shot but would it make sense to aim for a general plugin platform designed for DVCS systems (ie.
mainly bzr, git, mercurial)? Considering the rising popularity of these systems it might be something to consider.
Hopefully such a platform would help to offset the burden of maintenance.
Comment 48 rmorriso 2009-11-17 11:39:43 UTC
adding my vote for official support for GIT
Comment 49 vaelen 2009-11-21 02:41:58 UTC
Adding my vote for git support.
Comment 50 Petr Jiricka 2009-12-10 04:14:00 UTC
This is now the #3 top voted enhancement: http://wiki.netbeans.org/TopVoted. And considering that #1 and #2 (as well as #4) are in the plan for the next release, this issue is on track to become the #1 top voted enhancement, with a huge lead over the runners-up.
Comment 51 brettryan 2009-12-10 04:56:51 UTC
Absolutely fantastic, this is my #1 enhancement request.

Currently I use NB for a stand-alone VCS system for projects outside of NetBeans, adding Git support would have me covered nicely.
Comment 52 jessholle 2009-12-15 17:38:48 UTC
This is becoming very critical.

[I'm dumbfounded as to why Sun spent any time on Mercurial instead, when it was almost immediately clear that Git would be *much* more important.]
Comment 53 brettryan 2009-12-15 23:06:39 UTC
@jessholle I would presume the choice to use Mercurial would have been due to portability, Git is still not very well supported on Windows platforms and was certainly less when sun migrated to the mercurial repositories.
Comment 54 jessholle 2009-12-16 06:10:36 UTC
Hmmmm....

Git is well enough supported on Windows that I know of dozens of engineers who absolutely rely upon it every day on Windows -- and have for the better part of a year if not more.

When we first looked at Git and Mercurial (quite some time back and right around when Sun was announcing usage of Mercurial) we found both to work fine on Windows.  Sure Git didn't have a GUI for Windows yet, but it also vastly outperformed Mercurial in testing for large repositories.

Now comparative Git support is yet another wedge driving folk to Eclipse.
Comment 55 ioni969 2010-03-21 09:21:16 UTC
Hello,

 What is the status of integrating git VCS into Netbeans. I tried the git plugin on NB 6.8 and it does connect to github but the directory structure that it generates is completely different than that of the cloned project.

Regards,

Cristian
Comment 56 myschizobuddy 2010-03-21 12:59:24 UTC
two years have passed by to get git support in netbeans.
Comment 57 jessholle 2010-03-21 13:02:57 UTC
A move to Git is definitely in our future.  If NetBeans does not provide first class support for Git, then the world will just pass it by.  [Mercurial may be fine, but that's not where the market is going.]
Comment 58 Ondrej Vrabec 2010-04-24 16:53:22 UTC
*** Bug 184909 has been marked as a duplicate of this bug. ***
Comment 59 adolfoabegg 2010-05-13 15:38:29 UTC
+1 Git support is a must, please add it in the next release. Thank you :)
Comment 60 starsun 2010-05-15 13:53:30 UTC
Adding my vote for official support for GIT

Thanks.
Comment 61 ohcibi 2010-05-17 17:44:44 UTC
on more vote from me!
Comment 62 dgebhardt 2010-05-27 18:06:57 UTC
+1 - Looking forward to Git support in 6.9!
Comment 63 blissfull 2010-05-28 15:46:15 UTC
Again, while everybody waits for official GIT support, NBGIT works well with the 6.9 beta, and I use it daily, you can find the current source at http://github.com/myabc/nbgit , which is pretty easy to compile and install.
Comment 64 nbphpuser 2010-05-28 15:55:14 UTC
NBGIT doesn't work in nightly builds and rc's
Comment 65 PavelVD 2010-06-08 05:24:45 UTC
+1 add git please
Comment 66 maghiel 2010-06-18 11:43:32 UTC
My vote for git integrated into NB as well! 
More and more projects are migrating to git. 
And with the popularity of github...
Comment 67 matteo107 2010-06-18 18:40:48 UTC
+1 please add git support
Comment 68 witoldsz 2010-06-19 10:39:05 UTC
What about NetBeans 6.9 support for GIT?
I would like to use GIT for my new Java projects, but NetBeans falls in my way with this.
Comment 69 pcornelissen 2010-06-19 10:46:28 UTC
See: http://gitorious.org/projects/nbgit
Comment 70 XVilka 2010-06-23 09:39:53 UTC
it is not maintained anymore (nbgit)
And as we can see git now - very often use for development, and we need have git integrated deeply in NetBeans, as an svn support.
Comment 71 manandbytes 2010-07-08 10:03:41 UTC
(In reply to comment #70)

> it is not maintained anymore (nbgit)

May be not so _actively_ maintained as someone may expect, but it's not completely dead: there are some updates http://code.google.com/p/nbgit/updates/list and a new version is available http://code.google.com/p/nbgit/downloads/list?q=0.4
Comment 72 davibusanello 2010-08-08 12:17:54 UTC
git support please
Comment 73 Petr Jiricka 2010-08-13 07:21:51 UTC
Interesting info on languages at GitHub: http://www.r-chart.com/2010/08/github-stats-on-programming-languages.html
Comment 74 Tomas Stupka 2010-10-15 14:33:38 UTC
the VCS team has officially started working on the NetBeans Git plugin.

for more information see http://netbeans.org/projects/versioncontrol/pages/Git_main or ask questions at git@versioncontrol.netbeans.org
Comment 75 Tomas Stupka 2010-11-08 09:24:48 UTC
current development state available on the NetBeans dev UC
Comment 76 Ondrej Vrabec 2010-11-23 08:19:16 UTC
*** Bug 192267 has been marked as a duplicate of this bug. ***
Comment 77 Tomas Stupka 2010-11-29 14:09:28 UTC
git plugin development in progress, no need to keep this open anymore ...


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo