Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 131434 - AssertionError on (null visibility)
AssertionError on (null visibility)
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Code Model
6.x
All All
: P2 (vote)
: TBD
Assigned To: Alexander Simon
issues@cnd
61fixes1-fixed
:
Depends on: 131419
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-28 17:01 UTC by Vladimir Kvashin
Modified: 2008-06-04 08:34 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Stack trace (2.41 KB, text/plain)
2008-03-28 17:04 UTC, Vladimir Kvashin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Kvashin 2008-03-28 17:01:48 UTC
If after the exception described in #131419 occurs, I try closing the project, an assertion error occurs (see the stack
attached).
Comment 1 Vladimir Kvashin 2008-03-28 17:04:43 UTC
Created attachment 59300 [details]
Stack trace
Comment 2 Vladimir Kvashin 2008-03-28 17:09:29 UTC
The reason is that the creation of MethodImpl instance was broken: there was an exception in constructor (see issue
#131419). There fore the visibility field was not initialized and was left null.

When writing such object to persistence, an exception occurs.

Judging by code, if assertions are off (which is the case in the end user variant), then null is stored to persistence
correctly and restored upon reopen; so user won't see this assertion or related exception. 

That's why I leave it a P3.
Comment 3 Alexander Simon 2008-04-15 08:37:32 UTC
Assertion is P2 bug
Comment 4 Alexander Simon 2008-04-15 08:53:19 UTC
Code model IMHO has a serious implementation bug:
"There are no factory for code mode objects".
All objects are constructed by constructor that has too many responsibilities such as rendering object parameters,
putting on repository, registering in project.
Assertion/error on any phase of constructing object results in an intermediate state of model/repository.
The bug is example of this. Object was put on repository but rendering was failed and object wasn't created.
So the bug is a consequence of #131419.
The fix for #131419 resolve such situation.
I believe that bug fixed.
Comment 5 soldatov 2008-04-23 13:17:59 UTC
cannot reproduce this bug
verified in trunk (Build 200804230004)
Comment 6 rbalada 2008-04-29 15:06:10 UTC
Please provide information about changeset which fixed this issue in main. Without this information it cannot be
backported into NB 6.1 Patch 1.
Comment 7 jinb 2008-05-03 15:16:31 UTC
fixed in relese61_fixes branch by backporting of IZ 131419 fix
http://www.netbeans.org/issues/show_bug.cgi?id=131419


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo