Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 131419 - AssertionError in Boost project
AssertionError in Boost project
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Code Model
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Alexander Simon
issues@cnd
61fixes1-fixed
:
Depends on: 132404
Blocks: 131434
  Show dependency treegraph
 
Reported: 2008-03-28 15:51 UTC by soldatov
Modified: 2008-06-04 08:34 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2008-03-28 15:51:43 UTC
I created some time ago (in NB 6.0) Boost project. Today I opened it in NB 6.1 and I found AssertionError in
messages.log file.

function ast CSM_CTOR_DEFINITION without childs in file /export/projects/boost_1_33_1/boost/date_time/int_adapter.hpp
java.lang.AssertionError
at org.netbeans.modules.cnd.modelimpl.csm.FunctionImpl.initTemplate(FunctionImpl.java:225)
at org.netbeans.modules.cnd.modelimpl.csm.FunctionImpl.<init>(FunctionImpl.java:148)
at org.netbeans.modules.cnd.modelimpl.csm.MethodImpl.<init>(MethodImpl.java:69)
at org.netbeans.modules.cnd.modelimpl.csm.MethodDDImpl.<init>(MethodDDImpl.java:67)
at org.netbeans.modules.cnd.modelimpl.csm.MethodDDImpl.<init>(MethodDDImpl.java:63)
at org.netbeans.modules.cnd.modelimpl.csm.ClassImpl$ClassAstRenderer.render(ClassImpl.java:252)
at org.netbeans.modules.cnd.modelimpl.csm.ClassImpl.init(ClassImpl.java:358)
at org.netbeans.modules.cnd.modelimpl.csm.ClassImplSpecialization.init(ClassImplSpecialization.java:69)
at org.netbeans.modules.cnd.modelimpl.csm.ClassImplSpecialization.create(ClassImplSpecialization.java:75)
at org.netbeans.modules.cnd.modelimpl.csm.core.AstRenderer.render(AstRenderer.java:146)
at org.netbeans.modules.cnd.modelimpl.csm.core.AstRenderer.render(AstRenderer.java:84)
at org.netbeans.modules.cnd.modelimpl.csm.core.AstRenderer.render(AstRenderer.java:84)
at org.netbeans.modules.cnd.modelimpl.csm.core.AstRenderer.render(AstRenderer.java:70)
at org.netbeans.modules.cnd.modelimpl.csm.core.FileImpl.render(FileImpl.java:325)
at org.netbeans.modules.cnd.modelimpl.csm.core.FileImpl._parse(FileImpl.java:481)
at org.netbeans.modules.cnd.modelimpl.csm.core.FileImpl.parse(FileImpl.java:448)
at org.netbeans.modules.cnd.modelimpl.csm.core.FileImpl.ensureParsed(FileImpl.java:266)
at org.netbeans.modules.cnd.modelimpl.csm.core.ParserThread.run(ParserThread.java:90)
at org.netbeans.modules.cnd.modelimpl.csm.core.ParserThreadManager$Wrapper.run(ParserThreadManager.java:82)
at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)
function ast CSM_CTOR_DEFINITION without childs in file
/export/projects/boost_1_33_1/boost/spirit/core/non_terminal/subrule.hpp
Comment 1 Vladimir Kvashin 2008-03-28 22:32:12 UTC
A note concerning how to analyze the situation in a more simple way (via command line parsing).
If your main netbeans repository located in ${MAIN} and boost 1.33.1 - in ${BOOST}, then

1) 
sys_incl=`g++ -E -v -x c++ /dev/null  2>&1 | awk '\
    BEGIN { cnt=0; inside = 0; } \
    /#include "..." search starts here:/ { inside = 1; } \
    /#include <...> search starts here:/ { inside = 1; } \
    /End of search list/ { inside = 0; } \
    /^[^#].*/ { if( inside ) print "-I" $1 }'`

2). 
cd ${BOOST}

3) 
bash ${MAIN}/cnd.modelimpl/tracemodel.sh boost/date_time/int_adapter.hpp -I.  $sys_incl
Comment 2 Vladimir Kvashin 2008-03-28 22:43:28 UTC
I can not reproduce the situation.
It was probably fixed recently.

Could you please check it on the most recent build?
Comment 3 Vladimir Kvashin 2008-03-28 22:49:04 UTC
Probably it is platform specific (because on different platforms there might be different #defines and different active
code branches).

Could you check it on other platforms?

I tried on Solaris with GNU 3.4.3
Comment 4 soldatov 2008-04-03 16:06:34 UTC
I copied my boost project on sqa45.sfbay (sparc-S2) into /net/sqa45/export/home1/tester/boost_assert folder and I see
identical problem.
Comment 5 Alexander Simon 2008-04-09 17:18:48 UTC
Partly fixed in main trunk:
- correctly process AST renderer error.
- error has impact on one function. No impact on other file declarations.
- Fix for 132404 will fix this bug.
Change set:
http://hg.netbeans.org/main/rev/ac83cfc0cb69
Comment 6 Alexander Simon 2008-04-14 13:22:46 UTC
fixed
Comment 7 soldatov 2008-04-23 12:44:32 UTC
verified in trunk (Build 200804230004)
Comment 8 rbalada 2008-04-29 15:23:30 UTC
I've transplanted the changeset http://hg.netbeans.org/main/rev/ac83cfc0cb69
into release61_fixes repository as http://hg.netbeans.org/release61_fixes/rev/2c131aa42eba

changeset:   77508:2c131aa42eba
user:        Alexander Simon <alexvsimon@netbeans.org>
date:        Wed Apr 09 20:07:51 2008 +0400
summary:     fixing: IZ#131419:AssertionError in Boost project


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo