Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 131403 - After package rename - editor incorrectly reports error in classes
After package rename - editor incorrectly reports error in classes
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Source
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jan Lahoda
issues@java
:
: 130309 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-28 13:56 UTC by Jana Maleckova
Modified: 2008-03-31 09:16 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
messages log (133.13 KB, text/plain)
2008-03-28 16:35 UTC, Jiri Prox
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jana Maleckova 2008-03-28 13:56:12 UTC
Product Version: NetBeans IDE Dev (Build 200803251204)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; Cp1252; en_GB (nb)

Description:
============
have Java Desktop Application project with db connection
1. open e.g view class if it hasn't been already opened in editor
2. do refactor/rename of package with this class
see editor reports errors even though refactoring finished successfully 

workaround: close and open this class again in editor
Comment 1 Jiri Prox 2008-03-28 14:15:45 UTC
If can reproduce it with common j2se project. The code is correct but the fake errors makes refactoring to looks
unreliable (justification for higher priority).

See issue 130309 for more details

Product Version: NetBeans IDE Dev (Build 20080328094427)
Java: 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)
Comment 2 Jiri Prox 2008-03-28 14:19:57 UTC
*** Issue 130309 has been marked as a duplicate of this issue. ***
Comment 3 Jan Lahoda 2008-03-28 16:20:37 UTC
Can you reproduce reliably? Could you please try to reproduce on Linux? Could you please reproduce with:
-J-Dorg.netbeans.modules.java.source.usages.RepositoryUpdater.level=0
and send me the log? Thanks. (I was not yet able to reproduce on Linux :-( ).
Comment 4 Jiri Prox 2008-03-28 16:35:10 UTC
Created attachment 59296 [details]
messages log
Comment 5 Jiri Prox 2008-03-28 16:38:05 UTC
I've attached log from WinXP (fresh userdir and common J2se project user)
I'll try to reporduce it on Ubuntu Linux later, when I'll download actual build
Comment 6 Jiri Prox 2008-03-28 17:03:15 UTC
I'm unable to reproduce it on Linux (tested with the same build and project as on WinXP)
Comment 7 Jan Lahoda 2008-03-29 15:09:06 UTC
I was able to reliably reproduce a problem by adding delay to
refactoring.java/src/org/netbeans/modules/refactoring/java/plugins/RetoucheCommit.java, after calling commit on
ModificationResult. Presumably it is the problem described in this issue. I have tried to fix, please verify&test as
soon as possible. Thanks. The errors may appear temporarily, should be cleared without user intervention in few seconds.

http://hg.netbeans.org/main/rev/c593fde518d8
http://hg.netbeans.org/main/rev/64b6e3644e79
Comment 8 Jana Maleckova 2008-03-31 09:16:52 UTC
verified on

Product Version: NetBeans IDE Dev (Build 200803302302)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; Cp1252; en_GB (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo