Bug 131227 - Option for blank lines "After Anonymous Class Header"
Option for blank lines "After Anonymous Class Header"
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Editor
6.x
Other Windows XP
: P3 (vote)
: 7.2
Assigned To: Dusan Balek
issues@java
: PLAN
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-26 19:27 UTC by ghartmann
Modified: 2012-02-22 11:01 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ghartmann 2008-03-26 19:27:23 UTC
There should be an option for blank lines "After Anonymous Class Header". I use to add a blank line after the class 
header (like NetBeans default option), but I don't like a blank line after the class header of an anonymous class.

The blank line before "@Override" should not be configurable.
public class Test {

    JButton button;

    public void test() {
        button.addActionListener(new ActionListener() {

            @Override
            public void actionPerformed(ActionEvent e) {
                throw new UnsupportedOperationException("Not supported yet.");
            }
        });
    }
}
Comment 1 ghartmann 2008-03-26 19:28:24 UTC
Sorry: The blank line before "@Override" should BE configurable.
Comment 2 Vitezslav Stejskal 2008-03-27 14:40:15 UTC
Makes sense. Thanks
Comment 3 Vitezslav Stejskal 2008-06-23 14:32:48 UTC
*** Issue 137875 has been marked as a duplicate of this issue. ***
Comment 4 Dusan Balek 2012-02-21 12:49:45 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/4849ddcb0167
Comment 5 Quality Engineering 2012-02-22 11:01:18 UTC
Integrated into 'main-golden', will be available in build *201202220400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/4849ddcb0167
User: Dusan Balek <dbalek@netbeans.org>
Log: Minor Java formatting improvements (see issues #131227, #192629).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo