Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 13113 - java.lang.reflect.InvocationTargetException: null when changing JCBox's property
java.lang.reflect.InvocationTargetException: null when changing JCBox's property
Status: CLOSED FIXED
Product: guibuilder
Classification: Unclassified
Component: Code
3.x
All All
: P3 (vote)
: 3.x
Assigned To: Josef Kozak
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-22 15:41 UTC by peterp
Modified: 2003-06-30 18:32 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peterp 2001-06-22 15:41:40 UTC
1. run netbeans (last build should do)
2. create simple JFrame
3. add JComboBox 
4. try to change its selectedIndex property to say 3
Out comes this exception:

java.lang.reflect.InvocationTargetException: null
java.lang.reflect.InvocationTargetException: java.lang.IllegalArgumentException: 
setSelectedIndex: 5 out of bounds <---- here the number raises as you change 
property
        at javax.swing.JComboBox.setSelectedIndex(JComboBox.java:452)
        at java.lang.reflect.Method.invoke(Native Method)
        at 
org.netbeans.modules.form.RADProperty.setTargetValue(RADProperty.java:98)
        at 
org.netbeans.modules.form.FormProperty.setValue(FormProperty.java:196)
        at org.netbeans.modules.form.RADProperty.setValue(RADProperty.java:108)
        at 
org.openide.explorer.propertysheet.PropertyPanel$SimpleModel.setValue(PropertyPa
nel.java:1117)
        at 
org.openide.explorer.propertysheet.PropertyPanel$EditorListener.propertyChange(P
ropertyPanel.java:1354)
        at 
org.openide.util.WeakListener$PropertyChange.propertyChange(WeakListener.java:30
7)
        at 
org.netbeans.modules.form.FormPropertyEditor.firePropertyChange(FormPropertyEdit
or.java:352)
        at 
org.netbeans.modules.form.FormPropertyEditor.propertyChange(FormPropertyEditor.j
ava:83)
        at 
java.beans.PropertyEditorSupport.firePropertyChange(PropertyEditorSupport.java:2
39)
        at 
java.beans.PropertyEditorSupport.setValue(PropertyEditorSupport.java:53)
        at sun.beans.editors.IntEditor.setAsText(IntEditor.java:24)
        at 
org.netbeans.modules.form.FormPropertyEditor.setAsText(FormPropertyEditor.java:1
86)
        at 
org.openide.explorer.propertysheet.PropertyPanel.setAsText(PropertyPanel.java:99
8)
        at 
org.openide.explorer.propertysheet.PropertyPanel.access$1000(PropertyPanel.java:
39)
        at 
org.openide.explorer.propertysheet.PropertyPanel$WriteComponentListener.changeVa
lue(PropertyPanel.java:1213)
        at 
org.openide.explorer.propertysheet.PropertyPanel$WriteComponentListener.actionPe
rformed(PropertyPanel.java:1174)
        at javax.swing.JTextField.fireActionPerformed(JTextField.java:421)
        at javax.swing.JTextField.postActionEvent(JTextField.java:586)
        at 
javax.swing.JTextField$NotifyAction.actionPerformed(JTextField.java:696)
        at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1384)
        at javax.swing.JComponent.processKeyBinding(JComponent.java:2078)
        at javax.swing.JComponent.processKeyBindings(JComponent.java:2104)
        at javax.swing.JComponent.processKeyEvent(JComponent.java:2041)
        at java.awt.Component.processEvent(Component.java:3553)
        at java.awt.Container.processEvent(Container.java:1164)
        at java.awt.Component.dispatchEventImpl(Component.java:2593)
        at java.awt.Container.dispatchEventImpl(Container.java:1213)
        at java.awt.Component.dispatchEvent(Component.java:2497)
        at java.awt.LightweightDispatcher.processKeyEvent(Container.java:2155)
        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:2135)
        at java.awt.Container.dispatchEventImpl(Container.java:1200)
        at java.awt.Window.dispatchEventImpl(Window.java:914)
        at java.awt.Component.dispatchEvent(Component.java:2497)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:339)
        at 
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:1
31)
        at 
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:98)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:85)
Comment 1 peterp 2001-06-22 15:42:31 UTC
maybe this one is duplicate of #9631.
Comment 2 Marian Mirilovic 2001-06-26 13:23:56 UTC
[nb_dev](20010626), [jdk1.3.1](rc1)

It seems as problem arised after PropertySheet changes. 

Until build 207(new PropertySheet) arise "only" Dialog "Exception in setter
method property: selectedIndex.
Comment 3 Josef Kozak 2001-07-13 17:40:15 UTC
::: &#9658;&#9658;&#9658; absolutely reassigned &#9668;&#9668;&#9668;
Comment 4 Josef Kozak 2001-07-17 10:13:11 UTC
::: absolutely started
Comment 5 Josef Kozak 2001-07-18 13:16:53 UTC
InvocationTargetException is caught, "USER" annotated and thrown 
again.

::: fixed in dev only
Comment 6 Josef Kozak 2001-07-18 13:26:19 UTC
This one is not duplicate of #9631, even if they are very similar. 
#9631 pointed out on the issue that there was not the functionality 
in openide to show user dialog with localized message. Now this 
functionality exists, but we have to annotate our exception. That was 
problem of this issue (#13113), the annotating was missing.
Comment 7 Marian Mirilovic 2001-07-31 11:32:40 UTC
verified in [nb_dev](20010731)
Comment 8 Quality Engineering 2003-06-30 18:32:39 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo