Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 131056 - IDE freezed after "Duplicate" Configuration
IDE freezed after "Duplicate" Configuration
Status: VERIFIED FIXED
Product: javame
Classification: Unclassified
Component: Build System
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: Petr Suchomel
issues@mobility
61fixes1-fixed
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-25 15:35 UTC by kate
Modified: 2008-06-04 08:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
scr1 (75.62 KB, image/jpeg)
2008-03-25 15:37 UTC, kate
Details
scr2 (86.62 KB, image/jpeg)
2008-03-25 15:37 UTC, kate
Details
Console + Thread Dump (64.20 KB, text/plain)
2008-03-25 15:39 UTC, kate
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kate 2008-03-25 15:35:01 UTC
Product Version: NetBeans IDE Dev (Build 200803250006)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)

Mobility MIDP Application

1. Projects Window - Project Configurations node
2. Select some configuration node and try to move it [scr1]
3. After new placement "Duplicate" dialog appears [scr2]
4. Type in some name and press OK

IDE freezed

Dump follows.
Comment 1 kate 2008-03-25 15:37:18 UTC
Created attachment 59030 [details]
scr1
Comment 2 kate 2008-03-25 15:37:42 UTC
Created attachment 59031 [details]
scr2
Comment 3 kate 2008-03-25 15:39:14 UTC
Created attachment 59032 [details]
Console + Thread Dump
Comment 4 Karol Harezlak 2008-03-25 17:10:50 UTC
It is caused by the  AWT thread lock, inside of the ProjectConfigurationHelper.setActiveConfiguration(...)

*** This issue has been marked as a duplicate of 130760 ***
Comment 5 kate 2008-04-07 11:03:00 UTC
I do not consider this issue duplicate of 130760.

130760 was resolved & verified for rc build 200804040802 (Windows XP).

This issue still persists in 200804040802 (Windows XP).
Comment 6 Petr Suchomel 2008-04-23 17:08:34 UTC
Fixed in trunk, forgot to get CS while struggling with the mercurial again and forever. Same fix as for
http://www.netbeans.org/issues/show_bug.cgi?id=131053
Comment 7 Quality Engineering 2008-04-24 03:52:05 UTC
Issue '131056' Integrated in NB_Trunk_Production #154 : http://hg.netbeans.org/main/rev/0fd30fd6a217,
 with comment: Fix for #131053 & #131056 - deadlocks. Root cause is the same for both bugs
Comment 8 Lukas Hasik 2008-04-24 15:55:37 UTC
verified in trunk

Product Version: NetBeans IDE Dev (Build 200804240003)
Java: 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Userdir: F:\netbeans\userdir\nbDev0424
Comment 9 jinb 2008-04-29 19:17:46 UTC
fix backported into release61_fixes branch
Comment 10 jinb 2008-04-30 15:25:14 UTC
release61_fixes changeset: 77515: 5c8e63080ec1
Comment 11 Jaromir Uhrik 2008-05-19 16:31:38 UTC
I cannot reproduce this issue in 6.1fcs+patch1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo