Bug 131049 - Need for a Platform Module project based on a standard Library project
Need for a Platform Module project based on a standard Library project
Status: VERIFIED DUPLICATE of bug 70894
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: rmichalsky
issues@apisupport
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-25 14:49 UTC by plymouthjason
Modified: 2008-09-22 23:25 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description plymouthjason 2008-03-25 14:49:15 UTC
There should be a way to create a Platform Module project that is based on an existing Library project. When the module
is compiled, it should compile the library project, and import the resulting jar files.  It should also support
code-completion based on the library project's current sources.

It is very annoying to have to create a module-library project and manually update the jar file every time I modify the
associated library project; also, currently, module-library projects have NO support for code-completion.
Comment 1 Jana Maleckova 2008-09-17 09:05:29 UTC
reassign to apisupport for evaluation
Comment 2 rmichalsky 2008-09-17 11:10:14 UTC
Code completion works for me for library built from sources in NB 6.5, could you try it with 6.5?

Regarding manual copying of library jar, there is an easy workaround. Override target "netbeans-extra" in your Library
Wrapper's build.xml and copy the library jar from library project to binary-origin in the wrapper project. Like this:

<target name="netbeans-extra">
    <copy file="../MyLibProject/dist/MyLib.jar" todir="release/modules/ext" />
</target>

That way Library Wrapper always uses latest version of the library jar. Maybe we could support copying jar from external
location in New Library Wrapper Wizard.
Comment 3 rmichalsky 2008-09-17 11:17:04 UTC
See also issue #66275
Comment 4 rmichalsky 2008-09-18 16:24:56 UTC
See also
http://wiki.netbeans.org/DevFaqWrapperModules#section-DevFaqWrapperModules-Using%20a%20wrapper%20module%20for%20an%20existing%20project.

*** This issue has been marked as a duplicate of 70894 ***
Comment 5 Jesse Glick 2008-09-22 23:25:54 UTC
Yes.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo