Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 130987 - IllegalStateException: '@deprecated Use Editor Settings Storage API instead. ' org.netbeans.modules.java.editor.javadoc.DocPositions@1be9e3c4 token sequence dump: T[ 0]: " " <6330,6331> OTHER_TEXT[5]
IllegalStateException: '@deprecated Use Editor Settings Storage API instead. ...
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Javadoc
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jan Pokorsky
issues@java
http://statistics.netbeans.org/except...
:
: 131148 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-25 10:27 UTC by Max Sauer
Modified: 2009-10-22 17:19 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
source (4.33 KB, text/plain)
2008-03-27 15:07 UTC, unr303
Details
ide log (60.71 KB, text/plain)
2008-03-27 15:08 UTC, unr303
Details
stacktrace (7.89 KB, text/plain)
2008-06-03 12:12 UTC, stefan79
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Max Sauer 2008-03-25 10:27:50 UTC
Steps to reproduce:
-----------------
1) Open main/editor/src/org/netbeans/modules/editor/options/BaseOptions.java


Build: NetBeans IDE Dev (Build 20080325064414)
VM: Java HotSpot(TM) 64-Bit Server VM, 1.6.0_04-b12-45-optimized, Java(TM) SE Runtime Environment, 1.6.0_04-dp-b06-110
OS: Mac OS X, 10.5.2, x86_64
User comments: Opened main/editor/src/org/netbeans/modules/editor/options/BaseOptions.java
STACKTRACE: (first 10 lines)
java.lang.IllegalStateException: '@deprecated Use Editor Settings Storage API instead. '
org.netbeans.modules.java.editor.javadoc.DocPositions@1be9e3c4
token sequence dump: T[ 0]: " " <6330,6331> OTHER_TEXT[5] DefT, IHC=2106148048
T[ 1]: "@deprecated" <6331,6342> TAG[1] DefT, IHC=1057289235
T[ 2]: " " <6342,6343> OTHER_TEXT[5] DefT, IHC=1580477367
T[ 3]: "Use" <6343,6346> IDENT[0] DefT, IHC=857877426
T[ 4]: " " <6346,6347> OTHER_TEXT[5] DefT, IHC=140692824
T[ 5]: "Editor" <6347,6353> IDENT[0] DefT, IHC=244797621
T[ 6]: " " <6353,6354> OTHER_TEXT[5] DefT, IHC=1882432142
T[ 7]: "Settings" <6354,6362> IDENT[0] DefT, IHC=1307922990
T[ 8]: " " <6362,6363> OTHER_TEXT[5] DefT, IHC=619082238
T[ 9]: "Storage" <6363,6370> IDENT[0] DefT, IHC=356904351
T[10]: " " <6370,6371> OTHER_TEXT[5] DefT, IHC=569601186
T[11]: "API" <6371,6374> IDENT[0] DefT, IHC=1952518423
T[12]: " " <6374,6375> OTHER_TEXT[5] DefT, IHC=279525554
T[13]: "instead" <6375,6382> IDENT[0] DefT, IHC=1439250089
T[14]: "." <6382,6383> DOT[3] DefT, IHC=22044
        at org.netbeans.modules.java.editor.javadoc.DocPositions.resolve(DocPositions.java:189)
        at org.netbeans.modules.java.editor.javadoc.DocPositions.getTags(DocPositions.java:129)
        at org.netbeans.modules.java.editor.javadoc.JavadocImports.computeReferencedElements(JavadocImports.java:115)
        at org.netbeans.modules.java.editor.semantic.SemanticHighlighter$DetectorVisitor.handleJavadoc(SemanticHighlighter.java:686)
        at org.netbeans.modules.java.editor.semantic.SemanticHighlighter$DetectorVisitor.visitVariable(SemanticHighlighter.java:1069)
        at org.netbeans.modules.java.editor.semantic.SemanticHighlighter$DetectorVisitor.visitVariable(SemanticHighlighter.java:410)
        at com.sun.tools.javac.tree.JCTree$JCVariableDecl.accept(JCTree.java:724)
        at com.sun.source.util.TreePathScanner.scan(TreePathScanner.java:67)
        at org.netbeans.api.java.source.support.CancellableTreePathScanner.scan(CancellableTreePathScanner.java:91)
        at com.sun.source.util.TreeScanner.scanAndReduce(TreeScanner.java:80)
Comment 1 Jan Pokorsky 2008-03-25 18:31:44 UTC
Reproducible. Incorrect parsing of 1 line javadoc.
Comment 2 Jan Pokorsky 2008-03-25 19:11:56 UTC
fixed as http://hg.netbeans.org/main/rev/cf21663a4828
Comment 3 Max Sauer 2008-03-26 13:08:15 UTC
*** Issue 131148 has been marked as a duplicate of this issue. ***
Comment 4 unr303 2008-03-27 15:04:48 UTC
java.lang.ArrayIndexOutOfBoundsException: 0
	at org.netbeans.modules.java.editor.javadoc.DocPositions.addBlockTag(DocPositions.java:280)
	at org.netbeans.modules.java.editor.javadoc.DocPositions.resolve(DocPositions.java:168)
Caused: java.lang.IllegalStateException: ''
org.netbeans.modules.java.editor.javadoc.DocPositions@1dd5dca

happened on fresh build
Comment 5 unr303 2008-03-27 15:07:06 UTC
Created attachment 59212 [details]
source
Comment 6 unr303 2008-03-27 15:08:53 UTC
Created attachment 59214 [details]
ide log
Comment 7 Jan Pokorsky 2008-03-27 15:53:41 UTC
Unfortunately vkvashin rolled back the fix by incorrect merge #39944c4aa5bb yesterday as you can see at
http://hg.netbeans.org/main/log/cf21663a4828/java.editor/src/org/netbeans/modules/java/editor/javadoc/DocPositions.java.
Please try again with build from 27.3. and later or with fresh sources.
Comment 8 mrmorris 2008-05-09 13:10:25 UTC
Every time I submit this error from NetBeans, I end up on a website telling me:
Please update your current build of NetBeans to the target milestone 6.1 where the  issue #130987 is fixed.

...even though I am already running NetBeans 6.1! (Build 200804211638)
Comment 9 Jan Pokorsky 2008-05-15 12:45:51 UTC
mrmorris: please attach your {nb.userdir}/var/log/messages.log file here with description what you did when the
exception occurred. The originally reported issue seems to be fixed in NB 6.1.
Comment 10 stefan79 2008-06-03 12:12:49 UTC
Created attachment 62311 [details]
stacktrace
Comment 11 Exceptions Reporter 2008-07-03 10:41:38 UTC
This issue has already 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=40197
Comment 12 Jan Pokorsky 2008-07-08 14:30:49 UTC
Closing as fixed. The fix is valid for initial problem. The next is tracked as issue 139147.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo