Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 130857 - carriage return ignored in output window
carriage return ignored in output window
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Output Window
7.2
PC Linux
: P3 with 1 vote (vote)
: 7.4
Assigned To: Jaroslav Havlin
issues@platform
:
: 187939 200212 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-23 12:22 UTC by galinette
Modified: 2012-08-23 20:05 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description galinette 2008-03-23 12:22:55 UTC
The carriage return will be ignored or parsed wrong in output window.

An example producing wrong output:

for( int i=0; i < 10; i++ )
{
  System.out.print( i + "\r" );
  System.out.flush();
}
System.out.println( "done" );
Comment 1 Martin Entlicher 2011-01-22 00:35:33 UTC
*** Bug 187939 has been marked as a duplicate of this bug. ***
Comment 2 Jaroslav Havlin 2011-09-12 08:03:01 UTC
core-main/rev/f7d771b6c1f9

All of "\n", "\r", and "\r\n" are used as end of lines markers.
Comment 3 Quality Engineering 2011-09-13 16:07:52 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/f7d771b6c1f9
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #130857 - carriage return ignored in output window
Comment 4 Jaroslav Havlin 2011-09-15 08:34:41 UTC
*** Bug 200212 has been marked as a duplicate of this bug. ***
Comment 5 xav0989 2012-08-23 20:03:39 UTC
It would seem that this error is back again.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo