Bug 130472 - Profiler hangs after java.lang.ArrayIndexOutOfBoundsException
Profiler hangs after java.lang.ArrayIndexOutOfBoundsException
Status: RESOLVED DUPLICATE of bug 104573
Product: profiler
Classification: Unclassified
Component: Base
5.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@profiler
issues@profiler
: VISUALVM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-19 05:33 UTC by gulench
Modified: 2008-08-19 14:23 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Contents of %HOME%\.netbeans\5.5.1\var\log\messages.log (69.64 KB, text/plain)
2008-03-19 05:34 UTC, gulench
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gulench 2008-03-19 05:33:33 UTC
java.lang.ArrayIndexOutOfBoundsException is encountered while profiling a web application built using Struts & 
Hibernate. The profiler environment being used is:
- NetBeans Profiler 5.5.1
- Web application run using "modified JDK 1.4.2" on WebLogic 8.1 SP4

After this the profiled application do not respond; it does not respond to requests - user requests or from the IDE. 
Are there any workarounds; will upgrading to 6.0.1 help?

Stacktrace on the IDE is pasted below:

java.lang.ArrayIndexOutOfBoundsException
	at java.lang.System.arraycopy(Native Method)
	at com.sun.tools.profiler.instrumentation.SingleMethodScaner.initBytecodesArray(SingleMethodScaner.java:147)
	at com.sun.tools.profiler.instrumentation.SingleMethodScaner.setClassAndMethod(SingleMethodScaner.java:42)
	at com.sun.tools.profiler.instrumentation.MemoryProfMethodInstrumentor.hasNewOpcodes
(MemoryProfMethodInstrumentor.java:125)
	at com.sun.tools.profiler.instrumentation.ObjLivenessMethodInstrumentor.methodNeedsInstrumentation
(ObjLivenessMethodInstrumentor.java:42)
	at com.sun.tools.profiler.instrumentation.MemoryProfMethodInstrumentor.findAndMarkMethodsToInstrumentInClass
(MemoryProfMethodInstrumentor.java:107)
	at com.sun.tools.profiler.instrumentation.MemoryProfMethodInstrumentor.getMethodsToInstrumentUponClassLoad
(MemoryProfMethodInstrumentor.java:71)
	at 
com.sun.tools.profiler.instrumentation.Instrumentor.createFollowUpInstrumentMethodGroupResponseForMemoryProfiling
(Instrumentor.java:463)
	at com.sun.tools.profiler.instrumentation.Instrumentor.createFollowUpInstrumentMethodGroupResponse
(Instrumentor.java:157)
	at com.sun.tools.profiler.ProfilerClient.instrumentMethodGroupFollowUp(ProfilerClient.java:901)
	at com.sun.tools.profiler.ProfilerClient.access$2900(ProfilerClient.java:46)
[catch] at com.sun.tools.profiler.ProfilerClient$SeparateCmdExecutionThread.run(ProfilerClient.java:1603)
Comment 1 gulench 2008-03-19 05:34:57 UTC
Created attachment 58633 [details]
Contents of %HOME%\.netbeans\5.5.1\var\log\messages.log
Comment 2 J Bachorik 2008-03-29 12:52:16 UTC
changing milestone
Comment 3 Tomas Hurka 2008-08-19 14:23:04 UTC

*** This issue has been marked as a duplicate of 104573 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo