Bug 130368 - DomainCreationException on Ubuntu and IcedTea
DomainCreationException on Ubuntu and IcedTea
Status: RESOLVED WONTFIX
Product: installer
Classification: Unclassified
Component: Code
6.x
All Linux
: P3 (vote)
: TBD
Assigned To: issues@installer
issues@installer
: RELNOTE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 10:07 UTC by Jiri Vagner
Modified: 2008-03-18 12:49 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
log.zip (252.51 KB, application/octet-stream)
2008-03-18 10:09 UTC, Jiri Vagner
Details
glassfish configuration log (using ant -f setup.xml) (7.33 KB, text/plain)
2008-03-18 12:42 UTC, dlipin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Vagner 2008-03-18 10:07:48 UTC
On fresh Ubuntu 8.04 alpha 6 instalation I addded IcedTea JDK 7 (build 1.7.0-b24) via package manager and I installed NB
netbeans-trunk-nightly-200803171203-linux. After instalation installer noticed me about some error and points me to log
file. There is something wrong with configuration of GlassFish.


[2008-03-18 10:45:22.933]: org.netbeans.installer.utils.exceptions.InstallationException: Failed to create the default
domain
[2008-03-18 10:45:22.933]: 	at
org.netbeans.installer.products.glassfish.ConfigurationLogic.install(ConfigurationLogic.java:373)
[2008-03-18 10:45:22.933]: 	at org.netbeans.installer.product.components.Product.install(Product.java:329)
[2008-03-18 10:45:22.933]: 	at
org.netbeans.installer.wizard.components.actions.InstallAction.execute(InstallAction.java:151)
[2008-03-18 10:45:22.933]: 	at org.netbeans.installer.wizard.components.WizardAction$1.run(WizardAction.java:120)
[2008-03-18 10:45:22.933]: Caused by: org.netbeans.installer.utils.applications.GlassFishUtils$DomainCreationException:
"Could not create domain - error CLI130 occurred.
[2008-03-18 10:45:22.933]: 	at
org.netbeans.installer.utils.applications.GlassFishUtils.createDomain(GlassFishUtils.java:119)
[2008-03-18 10:45:22.933]: 	at org.netbeans.installer.utils.applications.GlassFishUtils.createDomain(GlassFishUtils.java:90)
[2008-03-18 10:45:22.933]: 	at org.netbeans.installer.utils.applications.GlassFishUtils.createDomain(GlassFishUtils.java:87)
[2008-03-18 10:45:22.933]: 	at
org.netbeans.installer.products.glassfish.ConfigurationLogic.install(ConfigurationLogic.java:364)
[2008-03-18 10:45:22.933]: 	... 3 more
Comment 1 Jiri Vagner 2008-03-18 10:09:39 UTC
Created attachment 58545 [details]
log.zip
Comment 2 dlipin 2008-03-18 10:29:02 UTC
The more interesting is the following part:

executing command: /home/jirka/java/glassfish-v2ur1/bin/asadmin create-domain --interactive=false --adminport 4848 --
user admin --passwordfile /home/jirka/java/glassfish-v2ur1/nbi-6942.tmp --instanceport 8080 --domainproperties 
http.ssl.port=8181 --savemasterpassword=true domain1, in directory: /home/jirka/java/glassfish-v2ur1
     [stdout]: Using port 4848 for Admin.
     [stdout]: Using port 8080 for HTTP Instance.
     [stdout]: Using default port 7676 for JMS.
     [stdout]: Using default port 3700 for IIOP.
     [stdout]: Using port 8181 for HTTP_SSL.
     [stdout]: Using default port 3820 for IIOP_SSL.
     [stdout]: Using default port 3920 for IIOP_MUTUALAUTH.
     [stdout]: Using default port 8686 for JMX_ADMIN.
     [stdout]: Domain being created with profile:developer, as specified by variable AS_ADMIN_PROFILE in configuration 
file.
     [stdout]: Security Store uses: JKS
     [stdout]: File {0} not found.
     [stderr]: CLI130 Could not create domain, domain1
     [return]: 1

I almost sure that it is the other limitation of glassfish with working on IcedTea JDK 7 in addition to
http://www.netbeans.org/issues/show_bug.cgi?id=122030
https://glassfish.dev.java.net/issues/show_bug.cgi?id=3869

It is already in the release notes :
http://www.netbeans.org/community/releases/61/relnotes.html#known_issues-installer


Jirka, could you please try install glassfish using its own installer?
You should edit setup.xml and modify check-java target, it is also will be helpful to add -DDebug to asadmin and attach 
the console log here.

If you could provide me access to such a system (inside swan) then I can do that by myself.

Thanks in advance,
Dmitry Lipin
Comment 3 dlipin 2008-03-18 12:42:24 UTC
Created attachment 58566 [details]
glassfish configuration log (using ant -f setup.xml)
Comment 4 dlipin 2008-03-18 12:49:45 UTC
Yes, it seems to be that glassfish still does not work fine with the latest IcedTea.
I`ve updated the glassfish issue with that information.

Marking the issue with RELNOTE keyword to add it futher to IcedTea installation limitation (next to 122030).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo