Bug 130317 - I18N - mac - multibyte characters don't show correctly in output window
I18N - mac - multibyte characters don't show correctly in output window
Status: RESOLVED DUPLICATE of bug 130311
Product: platform
Classification: Unclassified
Component: Output Window
6.x
Sun Mac OS X
: P3 (vote)
: TBD
Assigned To: t_h
issues@platform
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 18:16 UTC by Ken Frank
Modified: 2008-12-22 13:43 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
image (90.36 KB, image/gif)
2008-03-17 18:22 UTC, Ken Frank
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2008-03-17 18:16:21 UTC
using pseudo localized nb on mac osx, using the earlier mac jdk 1.6 since
newest one only for 64bit mac intel

using project with default encoding prop of utf-8 or of euc-jp

1. create j2se project
2. have a System.out.println with multibyte characters
3. run the java file.

4. in output window, the characters are shown as question marks  ( ???)

5. however, other messages like compilation ones from pseudo localized do show
correct multibyte.

see attached gif.
Comment 1 Ken Frank 2008-03-17 18:21:12 UTC
happens if project encoding is macroman ( ja_JP), euc-jp or utf-8

running ide - about box says encoding of os is macroman (ja_JP).
Comment 2 Ken Frank 2008-03-17 18:22:22 UTC
Created attachment 58511 [details]
image
Comment 3 ivan 2008-03-24 20:40:58 UTC
the output window is no longer built on top of
the terminal emulator
Comment 4 Milos Kleint 2008-03-26 10:11:21 UTC
tomasi, a duplicate of a bug you traced to ant support?
Comment 5 t_h 2008-03-26 10:21:28 UTC

*** This issue has been marked as a duplicate of 130311 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo