Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 130272 - BadLocationException: broken annotations
BadLocationException: broken annotations
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Hints & Annotations
6.x
All Linux
: P2 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
:
: 130404 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 11:40 UTC by Jan Pokorsky
Modified: 2008-03-18 17:59 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
BadLocationException (2.18 KB, text/plain)
2008-03-17 11:42 UTC, Jan Pokorsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Pokorsky 2008-03-17 11:40:10 UTC
[1.6.0_03-b05, nb build 080315]

The editor hints stopped working. None hint or breakpoint icon appear at the glyph gutter. On the other hand red
underwaves work as expected. Whenever I click on the gutter I get the following exception.
Comment 1 Jan Pokorsky 2008-03-17 11:42:03 UTC
Created attachment 58474 [details]
BadLocationException
Comment 2 Vitezslav Stejskal 2008-03-17 13:24:24 UTC
Umm, looks fine in today's dev build.

Product Version: NetBeans IDE Dev (Build 080317)
Java: 1.5.0_12; Java HotSpot(TM) Client VM 1.5.0_12-b04
System: Linux version 2.6.22-14-generic running on i386; UTF-8; en_US (nb)
Userdir: /home/vita/devel/netbeans/main/nbbuild/testuserdir
Comment 3 Marian Petras 2008-03-18 11:41:33 UTC
Many people experience the bug so I consider it confirmed and removed the INCOMPLETE keyword.

I guess the fact that yesterdays build was OK was caused by the recent unplanned rollback of many changes in the
NetBeans Mercurial repository.
Comment 4 Vitezslav Stejskal 2008-03-18 12:33:34 UTC
Related to issue #130171 and the recent changes in the initialization of editor panes.
http://hg.netbeans.org/main/rev/41c254473c98
Comment 5 Marian Petras 2008-03-18 14:10:47 UTC
Verified in a custom build 080318.
Comment 6 Vitezslav Stejskal 2008-03-18 17:59:05 UTC
*** Issue 130404 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo