Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 130135 - HgUtils.isIgnored does not match patterns starting with ^ correctly
HgUtils.isIgnored does not match patterns starting with ^ correctly
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-14 12:06 UTC by Padraig Obriain
Modified: 2008-03-20 09:50 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
proposed patch (832 bytes, patch)
2008-03-14 12:22 UTC, Padraig Obriain
Details | Diff
additional patch (1.59 KB, patch)
2008-03-19 16:42 UTC, Padraig Obriain
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Padraig Obriain 2008-03-14 12:06:33 UTC
If .hgignore contain a pattern starting with ^, e.g. ^nbbulid/netbeans Hgutils.isIgnored does not match this correctly.
Comment 1 Padraig Obriain 2008-03-14 12:07:43 UTC
The problem is that the matching is done against the absolute path name and not the path name relative to the location
of the .hgignore directory.
Comment 2 Padraig Obriain 2008-03-14 12:22:26 UTC
Created attachment 58383 [details]
proposed patch
Comment 3 Padraig Obriain 2008-03-14 14:55:30 UTC
In http://www.selenic.com/mercurial/bts/issue886 there is the statement that a "file is ignored if its path or the path
of any of its subcomponents is matched by a pattern in .hgignore".

HgUtils.isIgnored does not implement that.
Comment 4 Padraig Obriain 2008-03-18 10:29:01 UTC
Patch applied in changeset 73896:46a24feca988.
Comment 5 Padraig Obriain 2008-03-19 16:42:00 UTC
Created attachment 58679 [details]
additional patch
Comment 6 Padraig Obriain 2008-03-20 09:42:58 UTC
Additional patch pushed in changeset 74440:ddf405473eeb.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo