Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 130099 - All Text Properties made to "null"
All Text Properties made to "null"
Status: VERIFIED FIXED
Product: guibuilder
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: issues@guibuilder
issues@guibuilder
:
: 142691 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 22:27 UTC by bassim
Modified: 2008-08-04 18:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
A picture of the final result of the copy (106.02 KB, image/jpeg)
2008-03-21 16:16 UTC, bassim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bassim 2008-03-13 22:27:15 UTC
Copying a JPanel to another container (by choosing "Copy" then "Paste")makes all the property's labels (or JButtons)
text within the JPanel to "null"
Comment 1 Jan Stola 2008-03-14 07:01:42 UTC
I am sorry, I am not able to reproduce this issue. Could you, please, provide more details? Is the target container in 
the same form (in the same package)? Do you use automatic internationalization? Do you use swing application framework 
(e.g. JSR 296)? It would be ideal to attach a simple test-case. Thank you in advance.
Comment 2 bassim 2008-03-21 16:12:00 UTC
Here is a real test : i have two packages in the same level: "spherique" and "torique". in the "spherique" package, 
i have a JDialog "CorrectionsUI" that contains a JPanel and other simple components 
(JButtons, JLabels, JFormattedTextField and a JScrollPane/JTable).
I want to copy/paste this JDialog to the "torique" package. I have clicked  in a first time the "copy" menu related to 
the JDialog , then i have right clicked in a target package (torique) and choosen the second option of the the "Paste" 
menu who is "Refactor Copy". I changed the original name to "CorrectionsTorUI" and after copy finished, i opened the 
new JDialog.
look at the picture to understand !

Do you use automatic internationalization? No
Do you use swing application framework? Yes
Comment 3 bassim 2008-03-21 16:16:47 UTC
Created attachment 58852 [details]
A picture of the final result of the copy
Comment 4 Tomas Pavek 2008-03-25 10:33:05 UTC
This is actually a known problem - copy refactoring is not supported yet by the GUI builder (the necessary app framework
resources are not copied). See also http://wiki.netbeans.org/wiki/view/GUIBuilderRefactoring

As a workaround, you may try to create 'resources' subpackage under the target package and copy there manually the 
.properties file of the original form. (I.e. in your case copy 'spherique/resources/CorrectionsUI.properties' to
'torique/resources/CorrectionsTorUI.properties.)

*** This issue has been marked as a duplicate of 106831 ***
Comment 5 Tomas Pavek 2008-06-12 18:23:44 UTC
Reopening... to mark as fixed.
Comment 6 Tomas Pavek 2008-06-12 18:25:39 UTC
Support for copy refactoring implemented. The described test case should work now - application resources are copied
together with the form class.

http://hg.netbeans.org/main/rev/ddc7b3310db7
Comment 7 Jana Maleckova 2008-06-18 14:18:48 UTC
reported use case used in JDA project is verified in build 

Product Version: NetBeans IDE Dev (Build 20080618061212)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; Cp1252; en_GB (nb)
Comment 8 Jana Maleckova 2008-06-19 09:16:06 UTC
note for bassim: be aware that icons are not correctly handled. If you manage icons from resources as well (is "ON" as
default in JDA project), they won't be copied together with form class and ResourceBundle to new package. See issue 105850 
Comment 9 Tomas Pavek 2008-08-04 18:40:49 UTC
*** Issue 142691 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo