Bug 129891 - FX project doesn't recognize the classpath
FX project doesn't recognize the classpath
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Unsupported
6.x
All Windows XP
: P1 (vote)
: 6.x
Assigned To: Alexey Butenko
issues@javafx
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 12:56 UTC by Fabiola Rios
Modified: 2011-10-19 12:01 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabiola Rios 2008-03-12 12:56:41 UTC
FXCompiler version Milestone 2
Netbeans 6.0.1

Create a FX project
Create a JavaApplication project

FX project > Go to libraries and add the JavaApplication project, (or jar file)
set the imports build the project, the build file it doesn't recognize the classpath of the JavaApplication project.
===output window===
D:\SandBox\sandbox\fabi2\fxlab\solutions\exercise2\javaone2008demo\src\demo\Main.fx:9: package client does not exist
import client.Wservicemessage;
D:\SandBox\sandbox\fabi2\fxlab\solutions\exercise2\javaone2008demo\src\demo\Main.fx:46: cannot find symbol
symbol  : variable Wservicemessage
location: class demo.Main
            message = Wservicemessage.getActualMessage();
D:\SandBox\sandbox\fabi2\fxlab\solutions\exercise2\javaone2008demo\src\demo\Main.fx:99: cannot find symbol
symbol  : variable Wservicemessage
location: class demo.Main
                        Wservicemessage.message(inputMessage);
3 errors
====
When a run the FX project with verbose I found the follow:
=====
'-d'
'D:\SandBox\sandbox\fabi2\fxlab\solutions\exercise2\javaone2008demo\build\classes'
'-classpath'
'D:\SandBox\sandbox\fabi2\fxlab\solutions\exercise2\javaone2008demo\build\classes;C:\Program Files\NetBeans
6.0.1\javafx\modules\ext\javafx\compiler\javafxrt.jar;C:\Program Files\NetBeans
6.0.1\javafx\modules\ext\javafx\compiler\Scenario.jar;C:\Program Files\NetBeans
6.0.1\javafx\modules\ext\javafx\compiler\javafxc.jar'
'-target'
'1.5'
'-g'
'-sourc
======

I'd really appreciate if you take care of this bug, because I need it for J1 session.Thank you.=)
Comment 1 Alexei Mokeev 2008-03-12 13:44:15 UTC
Is it reproducible with Hg trunk ?
Comment 2 Alexey Butenko 2008-03-13 11:01:03 UTC
Fixed in trunk for 6.1
Comment 3 Fabiola Rios 2008-03-13 18:48:37 UTC
I test it today the fix in 6.1 Beta version, with the build 2008-03-13_11-54-39.zip branch from
http://openjfx.java.sun.com/hudson/job/openjfx-compiler/, and unfortunately it doesn't work.  :-( .
Comment 4 Fabiola Rios 2008-03-14 11:05:12 UTC
Now it works =),thanks

I tested it with JavaFX_NB_Plugin_trunk Mar 14, 2008 2:01:37 AM. and NetBeans 6.1 Beta.
Comment 5 Alexey Butenko 2008-03-17 12:43:57 UTC
fixed
Comment 6 Alexandr Scherbatiy 2008-03-25 16:28:04 UTC
verified
Comment 7 David Strupl 2011-10-19 12:01:33 UTC
Cleaning bugzilla categories ....


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo