Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 129276 - mercurial versioning view doesn't persist it's state
mercurial versioning view doesn't persist it's state
Status: RESOLVED DUPLICATE of bug 143300
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
:
Depends on: 129268
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 13:21 UTC by Tomas Stupka
Modified: 2008-09-23 09:33 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Stupka 2008-03-05 13:21:47 UTC
the mercurial versioning view is set to TopComponent.PERSISTENCE_ALWAYS in HgVersioningTopComponent but it does not
persist its actual state at all. The resulting effect is that the view gets opened after a netbeans restart without
having a context set - it's empty even if there were modifications before restart and a refresh from the toolbar doesn't
help either. 

note, that there is a problem in the versioning api -  VCSContext isn't serializable - see issue #129268.
i suggest you wait until issue 129268 gets fixed so you don't have to hack your way around with a parallel context
implementation like svn, clearcase & co did.
Comment 1 John Rice 2008-03-05 19:54:41 UTC
Should we change this to TopComponent.PERSISTENCE_NEVER, until this is fixed or should we just leave as is?
Comment 2 Tomas Stupka 2008-03-05 20:37:55 UTC
if you decide to stay with vcscontext and wait until 129268 gets fixed (not in  in 6.1) then setting PERSISTENCE_NEVER
would make sense as the way it works now is a bit strange. 


Comment 3 John Rice 2008-03-10 18:36:35 UTC
Change to TopComponent.PERSISTENCE_NEVER so behavior is consistent. Will reset to TopComponent.PERSISTENCE_ALWAYS when
129268 is available.

changeset:   72394:14405d40204e
tag:         tip
user:        jrice@netbeans.org
date:        Mon Mar 10 16:35:47 2008 +0000
summary:     #129276: mercurial versioning view doesn't persist it's state - needs #129268 to be fixed, for now disable
Status View persistence

Comment 4 John Rice 2008-05-19 10:52:21 UTC
Changing to enhancement, need VSContext persistence support
Comment 5 Tomas Stupka 2008-09-23 09:33:26 UTC

*** This issue has been marked as a duplicate of 143300 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo